summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-01-30 09:32:21 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-01-30 09:32:21 +0000
commitbebe942341c408936915a5bba2a3220599593435 (patch)
treee9f40dfdc8536c49c8f9d618dd706a95141b0b6f /net-irc
parentVersion bump. (diff)
downloadgentoo-2-bebe942341c408936915a5bba2a3220599593435.tar.gz
gentoo-2-bebe942341c408936915a5bba2a3220599593435.tar.bz2
gentoo-2-bebe942341c408936915a5bba2a3220599593435.zip
Added support for >=libnotify-0.7
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/xchat-2.8.8-libnotify07.patch24
-rw-r--r--net-irc/xchat/xchat-2.8.8-r1.ebuild4
3 files changed, 32 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index cc4d42a7ec5f..a0cf9e287ae3 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.292 2011/01/19 21:23:30 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.293 2011/01/30 09:32:21 polynomial-c Exp $
+
+ 30 Jan 2011; Lars Wendler <polynomial-c@gentoo.org> xchat-2.8.8-r1.ebuild,
+ +files/xchat-2.8.8-libnotify07.patch:
+ Added support for >=libnotify-0.7
19 Jan 2011; Lars Wendler <polynomial-c@gentoo.org> xchat-2.8.8-r1.ebuild:
Renamed xchatnogtk USE flag to gtk. Thanks to Pablo Barros for bringing my
diff --git a/net-irc/xchat/files/xchat-2.8.8-libnotify07.patch b/net-irc/xchat/files/xchat-2.8.8-libnotify07.patch
new file mode 100644
index 000000000000..2a6dce9a268d
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.8.8-libnotify07.patch
@@ -0,0 +1,24 @@
+diff -up xchat-2.8.8/src/fe-gtk/plugin-tray.c.libnotify07 xchat-2.8.8/src/fe-gtk/plugin-tray.c
+--- xchat-2.8.8/src/fe-gtk/plugin-tray.c.libnotify07 2010-11-15 17:32:15.708325783 -0500
++++ xchat-2.8.8/src/fe-gtk/plugin-tray.c 2010-11-15 18:05:17.322141789 -0500
+@@ -125,8 +125,9 @@ static void *nn_mod = NULL;
+ /* prototypes */
+ static gboolean (*nn_init) (char *);
+ static void (*nn_uninit) (void);
+-static void *(*nn_new_with_status_icon) (const gchar *summary, const gchar *message, const gchar *icon, GtkStatusIcon *status_icon);
+-static void *(*nn_new) (const gchar *summary, const gchar *message, const gchar *icon, GtkWidget *attach);
++/* recent versions of libnotify don't take the fourth GtkWidget argument, but passing an
++ * extra NULL argument will be fine */
++static void *(*nn_new) (const gchar *summary, const gchar *message, const gchar *icon, gpointer dummy);
+ static gboolean (*nn_show) (void *noti, GError **error);
+ static void (*nn_set_timeout) (void *noti, gint timeout);
+
+@@ -160,8 +161,6 @@ libnotify_notify_new (const char *title,
+ goto bad;
+ if (!g_module_symbol (nn_mod, "notify_uninit", (gpointer)&nn_uninit))
+ goto bad;
+- if (!g_module_symbol (nn_mod, "notify_notification_new_with_status_icon", (gpointer)&nn_new_with_status_icon))
+- goto bad;
+ if (!g_module_symbol (nn_mod, "notify_notification_new", (gpointer)&nn_new))
+ goto bad;
+ if (!g_module_symbol (nn_mod, "notify_notification_show", (gpointer)&nn_show))
diff --git a/net-irc/xchat/xchat-2.8.8-r1.ebuild b/net-irc/xchat/xchat-2.8.8-r1.ebuild
index 83241fb6ec70..903caf72c62e 100644
--- a/net-irc/xchat/xchat-2.8.8-r1.ebuild
+++ b/net-irc/xchat/xchat-2.8.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r1.ebuild,v 1.3 2011/01/19 21:23:30 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r1.ebuild,v 1.4 2011/01/30 09:32:21 polynomial-c Exp $
EAPI=2
@@ -43,6 +43,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-input-box4.patch
+ epatch "${FILESDIR}"/${P}-libnotify07.patch
+
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
# use libdir/xchat/plugins as the plugin directory