summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-09 16:18:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-09 16:18:31 +0000
commite59593022ead34052c29fa7582257705a8fea078 (patch)
tree0e61796e3561f4eedb85c4703393b30a90270fe8 /net-irc
parentVersion bump to 1.4.13. (diff)
downloadgentoo-2-e59593022ead34052c29fa7582257705a8fea078.tar.gz
gentoo-2-e59593022ead34052c29fa7582257705a8fea078.tar.bz2
gentoo-2-e59593022ead34052c29fa7582257705a8fea078.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #358039 by Juergen Rose. Remove now deprecated check for sys-devel/gcc >= 4.1 since minimum supported version is 4.4.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-gnome/ChangeLog8
-rw-r--r--net-irc/xchat-gnome/files/xchat-gnome-0.26.1-libnotify-0.7.patch27
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild13
3 files changed, 38 insertions, 10 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index 9efe11b8c512..79072f7f9752 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.61 2011/02/15 08:19:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.62 2011/03/09 16:18:31 ssuominen Exp $
+
+ 09 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xchat-gnome-0.26.1-r1.ebuild, +files/xchat-gnome-0.26.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #358039 by Juergen Rose.
+ Remove now deprecated check for sys-devel/gcc >= 4.1 since minimum supported
+ version is 4.4.
15 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
xchat-gnome-0.26.1-r1.ebuild, metadata.xml:
diff --git a/net-irc/xchat-gnome/files/xchat-gnome-0.26.1-libnotify-0.7.patch b/net-irc/xchat-gnome/files/xchat-gnome-0.26.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..386bd0dfd955
--- /dev/null
+++ b/net-irc/xchat-gnome/files/xchat-gnome-0.26.1-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- plugins/notify-osd/notify-osd.c
++++ plugins/notify-osd/notify-osd.c
+@@ -27,6 +27,10 @@
+ #include "xchat-plugin.h"
+ #include "xg-plugin.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define NOTIFY_OSD_NAME _("On-screen display")
+ #define NOTIFY_OSD_VERSION "0.1"
+ #define NOTIFY_OSD_DESCRIPTION _("Pops up notification of important messages when XChat-GNOME doesn't have the focus")
+@@ -67,7 +71,12 @@
+ gchar *escaped;
+
+ escaped = g_markup_escape_text (message, strlen(message));
+- notify = notify_notification_new (summary, escaped, NULL, NULL);
++ notify = notify_notification_new (summary, escaped, NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_icon_from_pixbuf (notify, notify_icon);
+ if (!notify_notification_show (notify, &error)) {
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
index 7874f9e0cb0e..b8f92c9bc0a6 100644
--- a/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
+++ b/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild,v 1.7 2011/02/15 08:19:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild,v 1.8 2011/03/09 16:18:31 ssuominen Exp $
EAPI="2"
GCONF_DEBUG="yes"
PYTHON_DEPEND="python? 2"
-inherit eutils gnome2 python toolchain-funcs
+inherit eutils gnome2 python
DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
HOMEPAGE="http://xchat-gnome.navi.cx/"
@@ -40,13 +40,6 @@ DEPEND="${RDEPEND}
# gnome-base/gnome-common needed when doing eautoreconf
pkg_setup() {
- if [[ $(gcc-major-version) -lt 4 || (
- $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 1 || (
- $(gcc-major-version) -eq 4 && $(gcc-minor-version) -eq 1 && $(gcc-micro-version) -lt 3 ) ) ]]; then
- ewarn "${P} requires >=sys-devel/gcc-4.1.3 to compile"
- die "Please select >=sys-devel/gcc-4.1.3"
- fi
-
# Per configure.ac, shm is disable because of upstream bug #565958
# --enable-shm
G2CONF="${G2CONF}
@@ -72,6 +65,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
gnome2_src_prepare
# Fix build with it documentation, bug #341173