summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-06 22:08:42 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-06 22:08:42 +0000
commite5b33b0832b48fae05e807a25b946e15a5041873 (patch)
treed4feee837526957d5b55d35f7dec20b57c7f1f2d /net-libs/c-client/c-client-2002d-r1.ebuild
parentrepoman: trim trailing whitespace (diff)
downloadgentoo-2-e5b33b0832b48fae05e807a25b946e15a5041873.tar.gz
gentoo-2-e5b33b0832b48fae05e807a25b946e15a5041873.tar.bz2
gentoo-2-e5b33b0832b48fae05e807a25b946e15a5041873.zip
repoman: trim trailing whitespace
Diffstat (limited to 'net-libs/c-client/c-client-2002d-r1.ebuild')
-rw-r--r--net-libs/c-client/c-client-2002d-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-libs/c-client/c-client-2002d-r1.ebuild b/net-libs/c-client/c-client-2002d-r1.ebuild
index 8df1cdc30482..35a066de8565 100644
--- a/net-libs/c-client/c-client-2002d-r1.ebuild
+++ b/net-libs/c-client/c-client-2002d-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002d-r1.ebuild,v 1.1 2003/08/11 09:07:41 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002d-r1.ebuild,v 1.2 2003/09/06 22:04:23 msterret Exp $
MY_PN=imap
MY_P=${MY_PN}-${PV}
@@ -21,17 +21,17 @@ RDEPEND="ssl? ( dev-libs/openssl )
DEPEND="${RDEPEND}
>=sys-libs/pam-0.72"
-inherit flag-o-matic
+inherit flag-o-matic
src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
- chmod -R ug+w ${S}
+ chmod -R ug+w ${S}
# alpha needs -fPIC
use pic || use alpha && append-flags -fPIC
-
+
# Modifications so we can build it optimially and correctly
cd ${S}/src/osdep/unix/
cp Makefile Makefile.orig
@@ -40,18 +40,18 @@ src_unpack() {
-e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
-e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
< Makefile.orig > Makefile
-
+
# Apply a patch to only build the stuff we need for c-client
cd ${S}
patch < ${FILESDIR}/${PV}-Makefile.patch
-
+
# Remove the pesky checks about SSL stuff
cd ${S}
cp Makefile Makefile.orig
grep -v 'read.*exit 1' <Makefile.orig >Makefile
}
-src_compile() {
+src_compile() {
if use ssl; then
make lnp SSLTYPE=unix || die
else
@@ -65,7 +65,7 @@ src_install() {
# Library binary
dolib.a c-client/c-client.a
dosym /usr/lib/c-client.a /usr/lib/libc-client.a
-
+
# Headers
insinto /usr/include/imap
doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h