summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2010-05-17 16:49:34 +0000
committerOlivier Crête <tester@gentoo.org>2010-05-17 16:49:34 +0000
commite64efa254438e0d4f0133d10d84edbf7c50a8c7e (patch)
tree39db2cc366fb3e2d8d025ead468225a896ad2a59 /net-libs/farsight2
parentwhitespace (diff)
downloadgentoo-2-e64efa254438e0d4f0133d10d84edbf7c50a8c7e.tar.gz
gentoo-2-e64efa254438e0d4f0133d10d84edbf7c50a8c7e.tar.bz2
gentoo-2-e64efa254438e0d4f0133d10d84edbf7c50a8c7e.zip
That version was stable on sparc and ia64
(Portage version: 2.1.8.3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-libs/farsight2')
-rw-r--r--net-libs/farsight2/ChangeLog5
-rw-r--r--net-libs/farsight2/farsight2-0.0.15.ebuild58
2 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/farsight2/ChangeLog b/net-libs/farsight2/ChangeLog
index 4ebbe76b6148..d14adfc7eef1 100644
--- a/net-libs/farsight2/ChangeLog
+++ b/net-libs/farsight2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/farsight2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.29 2010/05/17 14:53:22 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.30 2010/05/17 16:49:34 tester Exp $
+
+ 17 May 2010; Olivier Crête <tester@gentoo.org> +farsight2-0.0.15.ebuild:
+ That version was stable on sparc and ia64
17 May 2010; Olivier Crête <tester@gentoo.org> -farsight2-0.0.15.ebuild,
-farsight2-0.0.16.ebuild:
diff --git a/net-libs/farsight2/farsight2-0.0.15.ebuild b/net-libs/farsight2/farsight2-0.0.15.ebuild
new file mode 100644
index 000000000000..1e3e3fc499d4
--- /dev/null
+++ b/net-libs/farsight2/farsight2-0.0.15.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.15.ebuild,v 1.12 2010/05/17 16:49:34 tester Exp $
+
+EAPI="2"
+
+DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ia64 ~ppc ~ppc64 sparc ~x86"
+IUSE="python test msn upnp"
+SLOT="0"
+
+COMMONDEPEND=">=media-libs/gstreamer-0.10.23
+ >=media-libs/gst-plugins-base-0.10.23
+ >=dev-libs/glib-2.16
+ >=net-libs/libnice-0.0.9[gstreamer]
+ python? (
+ || ( >=dev-python/pygobject-2.16 >=dev-python/pygtk-2.12 )
+ >=dev-python/pygobject-2.12
+ >=dev-python/gst-python-0.10.10 )
+ upnp? ( net-libs/gupnp-igd )"
+
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.11
+ >=media-libs/gst-plugins-bad-0.10.13
+ || ( >=media-libs/gst-plugins-good-0.10.16
+ <media-libs/gst-plugins-bad-0.10.14 )
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.14 )"
+
+DEPEND="${COMMONDEPEND}
+ test? ( media-plugins/gst-plugins-vorbis
+ media-plugins/gst-plugins-speex )
+ dev-util/pkgconfig"
+
+src_configure() {
+ plugins="fsrtpconference,funnel,rtcpfilter,videoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog
+}
+
+src_test()
+{
+ use msn || { einfo "Tests disabled without msn use flag"; return ;}
+ if ! emake -j1 check; then
+ hasq test $FEATURES && die "Make check failed. See above for details."
+ hasq test $FEATURES || eerror "Make check failed. See above for details."
+ fi
+}