summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-20 12:30:48 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-20 12:30:48 +0000
commit5dd666f240e1eb6d51399bb11cf0edf8fbd9b595 (patch)
tree41c078867d8e4224905dc6c6ceb61594e13d93c7 /net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild
parentVersion bump, drop old (diff)
downloadgentoo-2-5dd666f240e1eb6d51399bb11cf0edf8fbd9b595.tar.gz
gentoo-2-5dd666f240e1eb6d51399bb11cf0edf8fbd9b595.tar.bz2
gentoo-2-5dd666f240e1eb6d51399bb11cf0edf8fbd9b595.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild')
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild
new file mode 100644
index 000000000000..5e9444cc525a
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.8.1.ebuild,v 1.1 2013/04/20 12:30:48 pacho Exp $
+
+EAPI="5"
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://live.gnome.org/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="gnome +introspection kerberos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ app-crypt/libsecret
+ dev-libs/json-glib
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.5.1:3
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ kerberos? (
+ app-crypt/gcr
+ app-crypt/mit-krb5 )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --with-facebook-client-id \
+ --enable-imap-smtp \
+ --enable-owncloud \
+ --with-windows-live-client-id \
+ $(use_enable kerberos)
+}