summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-19 13:54:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-19 13:54:10 +0000
commitd7cd907da7b4cfdcae07fd0b32b2f7fb46818a82 (patch)
treee77ee270e50bb44ba6c8b38ec7f76ee285fe8c7b /net-libs/gnutls/files
parentAdd cppserv-0.2.10 (diff)
downloadgentoo-2-d7cd907da7b4cfdcae07fd0b32b2f7fb46818a82.tar.gz
gentoo-2-d7cd907da7b4cfdcae07fd0b32b2f7fb46818a82.tar.bz2
gentoo-2-d7cd907da7b4cfdcae07fd0b32b2f7fb46818a82.zip
Version bump.
(Portage version: 13623-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls/files')
-rw-r--r--net-libs/gnutls/files/CVE-2009-1415.patch19
-rw-r--r--net-libs/gnutls/files/CVE-2009-1416.patch13
-rw-r--r--net-libs/gnutls/files/CVE-2009-1417.patch90
-rw-r--r--net-libs/gnutls/files/gnutls-2.6.0-openpgp-selftest.patch14
-rw-r--r--net-libs/gnutls/files/gnutls-2.7.8-lzo.patch16
5 files changed, 0 insertions, 152 deletions
diff --git a/net-libs/gnutls/files/CVE-2009-1415.patch b/net-libs/gnutls/files/CVE-2009-1415.patch
deleted file mode 100644
index 552775c59bfe..000000000000
--- a/net-libs/gnutls/files/CVE-2009-1415.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- pk-libgcrypt.c- 2009-04-23 10:59:06.000000000 +0200
-+++ pk-libgcrypt.c 2009-04-23 18:32:17.000000000 +0200
-@@ -418,7 +418,7 @@
- const gnutls_datum_t * signature,
- const gnutls_pk_params_st * pk_params)
- {
-- gcry_sexp_t s_sig, s_hash, s_pkey;
-+ gcry_sexp_t s_sig = NULL, s_hash = NULL, s_pkey = NULL;
- int rc = -1, ret;
- bigint_t hash;
- bigint_t tmp[2] = { NULL, NULL };
-@@ -511,6 +511,7 @@
- gcry_sexp_release (s_sig);
- gcry_sexp_release (s_hash);
- gcry_sexp_release (s_pkey);
-+ s_hash = s_pkey = s_sig = NULL;
-
- if (rc != 0)
- {
diff --git a/net-libs/gnutls/files/CVE-2009-1416.patch b/net-libs/gnutls/files/CVE-2009-1416.patch
deleted file mode 100644
index ebc540592820..000000000000
--- a/net-libs/gnutls/files/CVE-2009-1416.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/gnutls_pk.c b/lib/gnutls_pk.c
-index 1015c3a..a08349b 100644
---- a/lib/gnutls_pk.c
-+++ b/lib/gnutls_pk.c
-@@ -529,7 +529,7 @@ _generate_params (int algo, bigint_t * resarr, unsigned int *resarr_len,
- int ret;
- unsigned int i;
-
-- ret = _gnutls_pk_ops.generate (GNUTLS_PK_RSA, bits, &params);
-+ ret = _gnutls_pk_ops.generate (algo, bits, &params);
-
- if (ret < 0)
- {
diff --git a/net-libs/gnutls/files/CVE-2009-1417.patch b/net-libs/gnutls/files/CVE-2009-1417.patch
deleted file mode 100644
index 859c4a632a5c..000000000000
--- a/net-libs/gnutls/files/CVE-2009-1417.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-Index: gnutls-2.6.5/includes/gnutls/gnutls.h.in
-===================================================================
---- gnutls-2.6.5.orig/includes/gnutls/gnutls.h.in
-+++ gnutls-2.6.5/includes/gnutls/gnutls.h.in
-@@ -251,7 +251,13 @@ extern "C"
- */
- GNUTLS_CERT_SIGNER_NOT_FOUND = 64,
- GNUTLS_CERT_SIGNER_NOT_CA = 128,
-- GNUTLS_CERT_INSECURE_ALGORITHM = 256
-+ GNUTLS_CERT_INSECURE_ALGORITHM = 256,
-+
-+ /* Time verification.
-+ */
-+ GNUTLS_CERT_NOT_ACTIVATED = 512,
-+ GNUTLS_CERT_EXPIRED = 1024
-+
- } gnutls_certificate_status_t;
-
- typedef enum
-Index: gnutls-2.6.5/includes/gnutls/x509.h
-===================================================================
---- gnutls-2.6.5.orig/includes/gnutls/x509.h
-+++ gnutls-2.6.5/includes/gnutls/x509.h
-@@ -481,7 +481,13 @@ extern "C"
-
- /* Allow certificates to be signed using the broken MD5 algorithm.
- */
-- GNUTLS_VERIFY_ALLOW_SIGN_RSA_MD5 = 32
-+ GNUTLS_VERIFY_ALLOW_SIGN_RSA_MD5 = 32,
-+
-+ /* Disable checking of activation and expiration validity
-+ * periods of certificate chains. Don't set this unless you
-+ * understand the security implications.
-+ */
-+ GNUTLS_VERIFY_DISABLE_TIME_CHECKS = 64
- } gnutls_certificate_verify_flags;
-
- int gnutls_x509_crt_check_issuer (gnutls_x509_crt_t cert,
-Index: gnutls-2.6.5/lib/x509/verify.c
-===================================================================
---- gnutls-2.6.5.orig/lib/x509/verify.c
-+++ gnutls-2.6.5/lib/x509/verify.c
-@@ -493,6 +493,32 @@ _gnutls_x509_verify_certificate (const g
- }
- #endif
-
-+ /* Check activation/expiration times
-+ */
-+ if (!(flags & GNUTLS_VERIFY_DISABLE_TIME_CHECKS))
-+ {
-+ time_t t, now = time (0);
-+
-+ for (i = 0; i < clist_size; i++)
-+ {
-+ t = gnutls_x509_crt_get_activation_time (certificate_list[i]);
-+ if (t == (time_t) -1 || now < t)
-+ {
-+ status |= GNUTLS_CERT_NOT_ACTIVATED;
-+ status |= GNUTLS_CERT_INVALID;
-+ return status;
-+ }
-+
-+ t = gnutls_x509_crt_get_expiration_time (certificate_list[i]);
-+ if (t == (time_t) -1 || now > t)
-+ {
-+ status |= GNUTLS_CERT_EXPIRED;
-+ status |= GNUTLS_CERT_INVALID;
-+ return status;
-+ }
-+ }
-+ }
-+
- /* Verify the certificate path (chain)
- */
- for (i = clist_size - 1; i > 0; i--)
-Index: gnutls-2.6.5/src/common.c
-===================================================================
---- gnutls-2.6.5.orig/src/common.c
-+++ gnutls-2.6.5/src/common.c
-@@ -427,6 +427,10 @@ print_cert_vrfy (gnutls_session_t sessio
- {
- if (status & GNUTLS_CERT_SIGNER_NOT_FOUND)
- printf ("- Peer's certificate issuer is unknown\n");
-+ if (status & GNUTLS_CERT_NOT_ACTIVATED)
-+ printf ("- Peer's certificate chain uses not yet valid certificate\n");
-+ if (status & GNUTLS_CERT_EXPIRED)
-+ printf ("- Peer's certificate chain uses expired certificate\n");
- if (status & GNUTLS_CERT_INVALID)
- printf ("- Peer's certificate is NOT trusted\n");
- else
diff --git a/net-libs/gnutls/files/gnutls-2.6.0-openpgp-selftest.patch b/net-libs/gnutls/files/gnutls-2.6.0-openpgp-selftest.patch
deleted file mode 100644
index 661ca87bfffe..000000000000
--- a/net-libs/gnutls/files/gnutls-2.6.0-openpgp-selftest.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- tests/openpgp/Makefile.am.orig 2009-01-10 11:48:55.000000000 +1100
-+++ tests/openpgp/Makefile.am 2009-01-10 11:49:13.000000000 +1100
-@@ -30,10 +30,7 @@
-
- AM_CPPFLAGS = -I$(top_srcdir)/includes -I$(top_builddir)/includes \
- -I$(top_srcdir)/tests
--LDADD = -L$(top_builddir)/libextra -lgnutls-extra \
-- -L$(top_builddir)/lib -lgnutls \
-- -L$(top_builddir)/tests -lutils
--
-+LDADD = ../lib/libgnutls.la ../lib/libgnutls-extra.la ../libutils.la
- else
-
- EXTRA_DIST = $(openpgp_sources)
diff --git a/net-libs/gnutls/files/gnutls-2.7.8-lzo.patch b/net-libs/gnutls/files/gnutls-2.7.8-lzo.patch
deleted file mode 100644
index 5b0d280281f9..000000000000
--- a/net-libs/gnutls/files/gnutls-2.7.8-lzo.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commitdiff;h=e7eeb6c7c94cf838b3b199d4d7ec5aa1b6e1f656
-
---- lib/libgnutls.map
-+++ lib/libgnutls.map
-@@ -582,6 +582,11 @@
- _gnutls_read_uint24;
- _gnutls_get_cred;
- _gnutls_recv_int;
-+ # Internal symbols needed by libgnutls-extra for LZO:
-+ _gnutls_compression_algorithms;
-+ _gnutls_comp_algorithms_size;
-+ _gnutls_lzo1x_decompress_safe;
-+ _gnutls_lzo1x_1_compress;
- # Internal symbols needed by libgnutls-openssl:
- _gnutls_pkix1_asn;
- _gnutls_x509_parse_dn_oid;