summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-02-09 22:20:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-02-09 22:20:26 +0000
commit6f2a4ffed1a47c4d93ce3d041824d3d5a90d7292 (patch)
treeaad7e5ffd0d170ab633c1203da38a2bc94c0e00b /net-libs/gnutls/gnutls-1.2.10-r1.ebuild
parentfixed broken encoding in ChangeLog (diff)
downloadgentoo-2-6f2a4ffed1a47c4d93ce3d041824d3d5a90d7292.tar.gz
gentoo-2-6f2a4ffed1a47c4d93ce3d041824d3d5a90d7292.tar.bz2
gentoo-2-6f2a4ffed1a47c4d93ce3d041824d3d5a90d7292.zip
1.2.10 version bump for bug 122307.
(Portage version: 2.0.54)
Diffstat (limited to 'net-libs/gnutls/gnutls-1.2.10-r1.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-1.2.10-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/gnutls/gnutls-1.2.10-r1.ebuild b/net-libs/gnutls/gnutls-1.2.10-r1.ebuild
new file mode 100644
index 000000000000..6d5154960b37
--- /dev/null
+++ b/net-libs/gnutls/gnutls-1.2.10-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.2.10-r1.ebuild,v 1.1 2006/02/09 22:20:26 vanquirius Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="ftp://ftp.gnutls.org/pub/gnutls/${P}.tar.bz2"
+
+IUSE="zlib doc crypt"
+
+LICENSE="LGPL-2.1 GPL-2"
+# GPL-2 for the gnutls-extras library and LGPL for the gnutls library.
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+# Removed keywords awaiting >=dev-libs/libtasn1-0.2.10 keywords (bug #61944)
+# ~ia64 ~hppa
+
+RDEPEND=">=dev-libs/libgcrypt-1.2.2
+ >=app-crypt/opencdk-0.5.5
+ zlib? ( >=sys-libs/zlib-1.1 )
+ virtual/libc
+ >=dev-libs/lzo-2
+ >=dev-libs/libtasn1-0.2.11
+ dev-libs/libgpg-error"
+
+
+# crypt? ( >=app-crypt/opencdk-0.5.5 )
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/gcc
+ sys-devel/libtool"
+
+
+# gnutls has its own version of these. should maybe avoid using.
+# libtasn1
+# opencdk
+
+src_compile() {
+ # Needed for mips and probably others
+ gnuconfig_update
+
+ local myconf=""
+ # use crypt || myconf="${myconf} --disable-extra-pki --disable-openpgp-authentication"
+
+ econf \
+ `use_with zlib` \
+ --without-included-minilzo \
+ --without-included-libtasn1 \
+ --without-included-opencdk \
+ `use_enable doc gtk-doc` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ # OSX make doesn't handle -jx with x > 1 correctly here.
+ # Forcing it to be just one process, solves installation
+ # problems that arise here. Fabian Groffen (2005-07-09)
+ if use ppc-macos; then
+ emake -j1 DESTDIR=${D} install || die
+ else
+ emake DESTDIR=${D} install || die
+ fi
+
+
+ dodoc AUTHORS ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if use doc ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}