summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-01-20 15:30:05 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-01-20 15:30:05 +0000
commit6ff834cbae3b25e727e179dad1baa8858ad3cec1 (patch)
treea0421a81c05aaf12a0eb02c231239dcfa6d7dc4f /net-libs/gnutls
parentDepend on libsndfile 1.0.17-r1 or above as 1.0.11 is missing required headers... (diff)
downloadgentoo-2-6ff834cbae3b25e727e179dad1baa8858ad3cec1.tar.gz
gentoo-2-6ff834cbae3b25e727e179dad1baa8858ad3cec1.tar.bz2
gentoo-2-6ff834cbae3b25e727e179dad1baa8858ad3cec1.zip
Don't fail build on bindist, bug#202381, thanks to jacub
(Portage version: 2.1.4)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog5
-rw-r--r--net-libs/gnutls/gnutls-2.2.1.ebuild15
2 files changed, 13 insertions, 7 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index cd25b3dae911..5620395c3b88 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/gnutls
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.138 2008/01/18 23:08:15 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.139 2008/01/20 15:30:05 alonbl Exp $
+
+ 20 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> gnutls-2.2.1.ebuild:
+ Don't fail build on bindist, bug#202381, thanks to jacub
18 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> gnutls-2.2.1.ebuild:
Fix bug#202381, bug#203880
diff --git a/net-libs/gnutls/gnutls-2.2.1.ebuild b/net-libs/gnutls/gnutls-2.2.1.ebuild
index 0bce495a8f6d..230eb2f8f3e0 100644
--- a/net-libs/gnutls/gnutls-2.2.1.ebuild
+++ b/net-libs/gnutls/gnutls-2.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.2.1.ebuild,v 1.2 2008/01/18 23:08:15 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.2.1.ebuild,v 1.3 2008/01/20 15:30:05 alonbl Exp $
-inherit libtool autotools
+inherit libtool autotools eutils
DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
@@ -21,7 +21,7 @@ RDEPEND="dev-libs/libgpg-error
nls? ( virtual/libintl )
guile? ( dev-scheme/guile )
zlib? ( >=sys-libs/zlib-1.1 )
- lzo? ( >=dev-libs/lzo-2 )"
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
DEPEND="${RDEPEND}
sys-devel/libtool
doc? ( dev-util/gtk-doc )
@@ -34,8 +34,9 @@ pkg_setup() {
die
fi
if use lzo && use bindist; then
- eerror "lzo is not allowed in binary distribution of gnutls"
- die
+ ewarn "lzo support was disabled for binary distribution of gnutls"
+ ewarn "due to licensing issues. See Bug 202381 for details."
+ epause 5
fi
}
@@ -46,6 +47,8 @@ src_unpack() {
}
src_compile() {
+ local myconf
+ use bindist && myconf="--disable-lzo" || myconf="$(use_enable lzo)"
econf \
--without-included-opencdk \
$(use_with zlib) \
@@ -53,7 +56,7 @@ src_compile() {
$(use_enable nls) \
$(use_enable guile) \
$(use_enable doc gtk-doc) \
- || die
+ ${myconf}
emake || die
}