summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-08-11 00:15:33 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-08-11 00:15:33 +0000
commit8cf439ce5d2d4b42de86ea50282f73899a770ad1 (patch)
treeb2fc76fdaad6e814c4533585b7e495ce727ee8a4 /net-libs/ldns
parentFix compile with make-3.82, bug #332131 by polynomial-c. (diff)
downloadgentoo-2-8cf439ce5d2d4b42de86ea50282f73899a770ad1.tar.gz
gentoo-2-8cf439ce5d2d4b42de86ea50282f73899a770ad1.tar.bz2
gentoo-2-8cf439ce5d2d4b42de86ea50282f73899a770ad1.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ChangeLog7
-rw-r--r--net-libs/ldns/ldns-1.6.6.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
index 42657252691a..9b76efffc982 100644
--- a/net-libs/ldns/ChangeLog
+++ b/net-libs/ldns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ldns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.10 2010/06/17 00:20:52 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.11 2010/08/11 00:15:33 matsuu Exp $
+
+*ldns-1.6.6 (11 Aug 2010)
+
+ 11 Aug 2010; MATSUU Takuto <matsuu@gentoo.org> +ldns-1.6.6.ebuild:
+ Version bumped.
17 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> ldns-1.6.5.ebuild:
Removed libtool archive files.
diff --git a/net-libs/ldns/ldns-1.6.6.ebuild b/net-libs/ldns/ldns-1.6.6.ebuild
new file mode 100644
index 000000000000..c2f0a0a86fb6
--- /dev/null
+++ b/net-libs/ldns/ldns-1.6.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.6.ebuild,v 1.1 2010/08/11 00:15:33 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit multilib python
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="doc python ssl vim-syntax"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) \
+ $(use_with python pyldns) \
+ --disable-rpath || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake doxygen || die "emake doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog README* || die "dodoc failed"
+
+ if use python ; then
+ rm "${ED}/usr/$(get_libdir)"/python*/site-packages/_ldns.*a || die
+ fi
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim || die "doins libdns.vim failed"
+ fi
+}