summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-16 23:52:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-16 23:52:05 +0000
commitfc56a59c6cadabbaf618e7f6234e43275a083798 (patch)
tree5f5de8dcfaa49a42eae0e0f2b2d056ac9fe53f9e /net-libs/ldns
parentqt4 xconfig, fix for apci lid open error in nouveau driver and a fix for some... (diff)
downloadgentoo-2-fc56a59c6cadabbaf618e7f6234e43275a083798.tar.gz
gentoo-2-fc56a59c6cadabbaf618e7f6234e43275a083798.tar.bz2
gentoo-2-fc56a59c6cadabbaf618e7f6234e43275a083798.zip
Version bumped. Added python USE flag.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ChangeLog7
-rw-r--r--net-libs/ldns/ldns-1.6.5.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
index 3d17dffadf3c..d108005e831e 100644
--- a/net-libs/ldns/ChangeLog
+++ b/net-libs/ldns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ldns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.8 2010/04/02 19:33:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.9 2010/06/16 23:52:05 matsuu Exp $
+
+*ldns-1.6.5 (16 Jun 2010)
+
+ 16 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +ldns-1.6.5.ebuild:
+ Version bumped. Added python USE flag.
02 Apr 2010; Fabian Groffen <grobian@gentoo.org> ldns-1.6.4.ebuild:
Marked ~ppc-macos and ~x64-macos, bug #312015
diff --git a/net-libs/ldns/ldns-1.6.5.ebuild b/net-libs/ldns/ldns-1.6.5.ebuild
new file mode 100644
index 000000000000..f1a9d4efdc4e
--- /dev/null
+++ b/net-libs/ldns/ldns-1.6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.5.ebuild,v 1.1 2010/06/16 23:52:05 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit python
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="doc python ssl vim-syntax"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) \
+ $(use_with python pyldns) \
+ --disable-rpath || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake doxygen || die "emake doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog README* || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim || die "doins libdns.vim failed"
+ fi
+}