summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-01-01 18:05:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-01-01 18:05:20 +0000
commit8f854d2026712994ce5cdb6626fd429a7133e38a (patch)
tree22047524bf3d7f9f7ea7cffec0c2e2f66f738150 /net-libs/libktorrent
parentalpha/arm/ia64/sh/sparc/x86 stable wrt #394929 (diff)
downloadgentoo-2-8f854d2026712994ce5cdb6626fd429a7133e38a.tar.gz
gentoo-2-8f854d2026712994ce5cdb6626fd429a7133e38a.tar.bz2
gentoo-2-8f854d2026712994ce5cdb6626fd429a7133e38a.zip
Fix underlinking in test programs, bug 371897
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/ChangeLog8
-rw-r--r--net-libs/libktorrent/files/libktorrent-1.1.3-underlinking.patch10
-rw-r--r--net-libs/libktorrent/libktorrent-1.1.3.ebuild7
3 files changed, 21 insertions, 4 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index 060e54cc7ae4..4c707cf4b430 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libktorrent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.26 2011/12/30 23:02:56 dilfridge Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.27 2012/01/01 18:05:20 dilfridge Exp $
+
+ 01 Jan 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ libktorrent-1.1.3.ebuild, +files/libktorrent-1.1.3-underlinking.patch:
+ Fix underlinking in test programs, bug 371897
30 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+libktorrent-1.1.1.ebuild:
diff --git a/net-libs/libktorrent/files/libktorrent-1.1.3-underlinking.patch b/net-libs/libktorrent/files/libktorrent-1.1.3-underlinking.patch
new file mode 100644
index 000000000000..85ef103213b0
--- /dev/null
+++ b/net-libs/libktorrent/files/libktorrent-1.1.3-underlinking.patch
@@ -0,0 +1,10 @@
+diff -ruN libktorrent-1.1.3.orig/src/util/tests/CMakeLists.txt libktorrent-1.1.3/src/util/tests/CMakeLists.txt
+--- libktorrent-1.1.3.orig/src/util/tests/CMakeLists.txt 2011-11-22 18:21:28.000000000 +0100
++++ libktorrent-1.1.3/src/util/tests/CMakeLists.txt 2012-01-01 19:03:45.000000000 +0100
+@@ -14,4 +14,4 @@
+
+ set(fileopstest_SRCS fileopstest.cpp)
+ kde4_add_unit_test(fileopstest TESTNAME fileopstest ${fileopstest_SRCS})
+-target_link_libraries( fileopstest ${KDE4_KDECORE_LIBS} ${QT_QTTEST_LIBRARY} ktorrent)
+\ Kein Zeilenumbruch am Dateiende.
++target_link_libraries( fileopstest ${KDE4_KDECORE_LIBS} ${KDE4_SOLID_LIBS} ${QT_QTTEST_LIBRARY} ktorrent)
diff --git a/net-libs/libktorrent/libktorrent-1.1.3.ebuild b/net-libs/libktorrent/libktorrent-1.1.3.ebuild
index 014d8d4737bd..e3eb106cb4ba 100644
--- a/net-libs/libktorrent/libktorrent-1.1.3.ebuild
+++ b/net-libs/libktorrent/libktorrent-1.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.1.3.ebuild,v 1.1 2011/12/30 22:58:46 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.1.3.ebuild,v 1.2 2012/01/01 18:05:20 dilfridge Exp $
EAPI=4
@@ -38,12 +38,15 @@ IUSE="debug"
RDEPEND="
app-crypt/qca:2
dev-libs/gmp
+ $(add_kdebase_dep solid)
"
DEPEND="${RDEPEND}
dev-libs/boost
sys-devel/gettext
"
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )
+
src_prepare() {
kde4-base_src_prepare
# do not build non-installed example binary