summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-06 01:20:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-06 01:20:08 +0000
commit18c93dc73fdedb3f75b8b8566f83017df96e3935 (patch)
treeb48935bd8fbd37c8ca1357b0e161770c539ad7a0 /net-libs/libmicrohttpd
parentBeta channel bump. (diff)
downloadgentoo-2-18c93dc73fdedb3f75b8b8566f83017df96e3935.tar.gz
gentoo-2-18c93dc73fdedb3f75b8b8566f83017df96e3935.tar.bz2
gentoo-2-18c93dc73fdedb3f75b8b8566f83017df96e3935.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog10
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.25.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 18d3f4a3911c..ce6abd22cf07 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.28 2012/12/26 16:39:50 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.29 2013/02/06 01:20:08 blueness Exp $
+
+*libmicrohttpd-0.9.25 (06 Feb 2013)
+
+ 06 Feb 2013; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.25.ebuild:
+ Version bump
26 Dec 2012; Anthony G. Basile <blueness@gentoo.org>
-libmicrohttpd-0.9.19.ebuild, -libmicrohttpd-0.9.20.ebuild,
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.25.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.25.ebuild
new file mode 100644
index 000000000000..98fa2aaf5f7a
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.25.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.25.ebuild,v 1.1 2013/02/06 01:20:08 blueness Exp $
+
+EAPI="4"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="messages ssl static-libs test"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}