summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-27 18:05:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-27 18:05:44 +0000
commit94dc41071da2ebab3f41d73fc8ae97a5215f6b76 (patch)
tree4bb28c937bf71b3734548f29c0652c5a22ab4b7e /net-libs/libproxy
parentMask net-analyzer/iptraf (bug #305781). (diff)
downloadgentoo-2-94dc41071da2ebab3f41d73fc8ae97a5215f6b76.tar.gz
gentoo-2-94dc41071da2ebab3f41d73fc8ae97a5215f6b76.tar.bz2
gentoo-2-94dc41071da2ebab3f41d73fc8ae97a5215f6b76.zip
revbump, cleanup
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/ChangeLog8
-rw-r--r--net-libs/libproxy/libproxy-0.4.6-r2.ebuild (renamed from net-libs/libproxy/libproxy-0.4.6-r1.ebuild)54
2 files changed, 24 insertions, 38 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index ab2fc93fad0d..f8ae658444ef 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.56 2011/03/22 21:48:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.57 2011/03/27 18:05:44 ssuominen Exp $
- 22 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> libproxy-0.4.6-r1.ebuild,
+*libproxy-0.4.6-r2 (27 Mar 2011)
+
+ 27 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +libproxy-0.4.6-r2.ebuild,
+files/libproxy-0.4.6-xulrunner-2.patch:
- Fix compability with net-libs/xulrunner >= 2 wrt #359879 by Justin Lecher.
+ Fix building with net-libs/xulrunner >= 2.0 wrt #359879 by Justin Lecher.
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libproxy-0.4.6.ebuild:
Fix slot-deps on gnome libs
diff --git a/net-libs/libproxy/libproxy-0.4.6-r1.ebuild b/net-libs/libproxy/libproxy-0.4.6-r2.ebuild
index 15ecf60753cd..8026185e0744 100644
--- a/net-libs/libproxy/libproxy-0.4.6-r1.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.6-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r1.ebuild,v 1.4 2011/03/22 21:48:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r2.ebuild,v 1.1 2011/03/27 18:05:44 ssuominen Exp $
-EAPI="2"
-PYTHON_DEPEND="python? 2:2.5"
+EAPI=3
+PYTHON_DEPEND="python? 2:2.6"
-inherit cmake-utils eutils multilib python portability
+inherit cmake-utils multilib mono python
DESCRIPTION="Library for automatic proxy configuration management"
HOMEPAGE="http://code.google.com/p/libproxy/"
@@ -16,34 +16,34 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="gnome kde mono networkmanager perl python test vala webkit xulrunner"
-RDEPEND="
- gnome? ( gnome-base/gconf:2 )
- kde? ( >=kde-base/kdelibs-4.3 )
+RDEPEND="gnome? ( gnome-base/gconf:2 )
+ kde? ( >=kde-base/kdelibs-4.4.5 )
mono? ( dev-lang/mono )
networkmanager? ( net-misc/networkmanager )
perl? ( dev-lang/perl )
vala? ( dev-lang/vala:0.10 )
webkit? ( net-libs/webkit-gtk:2 )
xulrunner? ( >=net-libs/xulrunner-1.9.1:1.9 )"
-
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.19"
+ dev-util/pkgconfig"
-DOCS="AUTHORS NEWS README ChangeLog"
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-mozjs-link_directory.patch )
-PATCHES=(
- "${FILESDIR}"/${P}-mozjs-link_directory.patch
- "${FILESDIR}"/${P}-xulrunner-2.patch
- )
+ # http://code.google.com/p/libproxy/source/detail?r=791
+ has_version ">=net-libs/xulrunner-2" && \
+ PATCHES+=( "${FILESDIR}"/${P}-xulrunner-2.patch )
+
+ DOCS="AUTHORS ChangeLog NEWS README"
-pkg_setup() {
if use python; then
python_set_active_version 2
+ python_pkg_setup
fi
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DPERL_VENDORINSTALL=ON
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
@@ -58,30 +58,14 @@ src_configure() {
$(cmake-utils_use_with xulrunner MOZJS)
$(cmake-utils_use test BUILD_TESTING)
)
- cmake-utils_src_configure
-}
-src_compile() {
- # Prevent access violation when building with mono support
- export MONO_SHARED_DIR="${T}/shared"
- cmake-utils_src_compile
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/libproxy.so.0
+ cmake-utils_src_configure
}
pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libproxy.so.0
-
- if use python; then
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/${PN}.py
- fi
+ use python && python_mod_optimize ${PN}.py
}
pkg_postrm() {
- if use python; then
- python_mod_cleanup $(python_get_sitedir)/${PN}.py
- fi
+ use python && python_mod_cleanup ${PN}.py
}