summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-06 20:42:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-06 20:42:57 +0000
commit810d1e0051d5c8a00d7eb74f8cf3295936613d80 (patch)
treeae1f2a83ab9e0560f8617d1881340f5484f828ce /net-libs/librsync/librsync-0.9.7-r1.ebuild
parentRemove old. (diff)
downloadgentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.tar.gz
gentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.tar.bz2
gentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.zip
Add upstream patch to support +4GiB file sizes. Bug #142945 by Vadim. Add
epunt_cxx for bug #185600 by Laurence Withers. Maintainer-needed commit. (Portage version: 2.1.3.12)
Diffstat (limited to 'net-libs/librsync/librsync-0.9.7-r1.ebuild')
-rw-r--r--net-libs/librsync/librsync-0.9.7-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/librsync/librsync-0.9.7-r1.ebuild b/net-libs/librsync/librsync-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..112de79858da
--- /dev/null
+++ b/net-libs/librsync/librsync-0.9.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/librsync-0.9.7-r1.ebuild,v 1.1 2007/10/06 20:42:57 dirtyepic Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Flexible remote checksum-based differencing"
+HOMEPAGE="http://librsync.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Bug #142945
+ epatch "${FILESDIR}"/${P}-huge-files.patch
+
+ # Bug #185600
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS AUTHORS THANKS README TODO
+}