summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-17 03:46:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-17 03:46:23 +0000
commitdc552b92a39418fa2cf2baab0954b03611baff52 (patch)
tree06c8dfa2835a3dbb9b2a90a1a489a16c0185a662 /net-libs/libssh/libssh-0.1.ebuild
parentadded virtual/blas (diff)
downloadgentoo-2-dc552b92a39418fa2cf2baab0954b03611baff52.tar.gz
gentoo-2-dc552b92a39418fa2cf2baab0954b03611baff52.tar.bz2
gentoo-2-dc552b92a39418fa2cf2baab0954b03611baff52.zip
initial ebuild #49769
Diffstat (limited to 'net-libs/libssh/libssh-0.1.ebuild')
-rw-r--r--net-libs/libssh/libssh-0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/libssh/libssh-0.1.ebuild b/net-libs/libssh/libssh-0.1.ebuild
new file mode 100644
index 000000000000..30416de8538e
--- /dev/null
+++ b/net-libs/libssh/libssh-0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-0.1.ebuild,v 1.1 2004/05/17 03:46:23 vapier Exp $
+
+DESCRIPTION="access a working SSH implementation by means of a library"
+HOMEPAGE="http://0xbadc0de.be/projects/sshlib.html"
+SRC_URI="http://www.0xbadc0de.be/projects/libssh/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ dev-libs/openssl"
+
+src_install() {
+ make install prefix=${D}/usr || die "einstall failed"
+ newbin ssh ${PN}-ssh
+ dosym ${PN}-ssh /usr/bin/${PN}-sftp
+ [ ! -e "${ROOT}/usr/bin/ssh" ] && dosym ${PN}-ssh /usr/bin/ssh
+ [ ! -e "${ROOT}/usr/bin/sftp" ] && dosym ${PN}-ssh /usr/bin/sftp
+ chmod a-x ${D}/usr/include/libssh/*
+}