summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-13 08:30:06 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-13 08:30:06 +0000
commit2625d40e4489a6d0243f5e3e000b16bae1faee8b (patch)
treeb66148f9348299c668300c3dfe51d0fcdf32759c /net-libs/libssh2
parentEnable multilib support, required for net-misc/curl. (diff)
downloadgentoo-2-2625d40e4489a6d0243f5e3e000b16bae1faee8b.tar.gz
gentoo-2-2625d40e4489a6d0243f5e3e000b16bae1faee8b.tar.bz2
gentoo-2-2625d40e4489a6d0243f5e3e000b16bae1faee8b.zip
Enable multilib support, required for net-misc/curl.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.4.3-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 4be332b86060..778661c03e7a 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.84 2014/03/01 22:37:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.85 2014/06/13 08:30:06 mgorny Exp $
+
+*libssh2-1.4.3-r1 (13 Jun 2014)
+
+ 13 Jun 2014; Michał Górny <mgorny@gentoo.org> +libssh2-1.4.3-r1.ebuild:
+ Enable multilib support, required for net-misc/curl.
01 Mar 2014; Michał Górny <mgorny@gentoo.org> libssh2-1.4.2.ebuild,
libssh2-1.4.3.ebuild:
diff --git a/net-libs/libssh2/libssh2-1.4.3-r1.ebuild b/net-libs/libssh2/libssh2-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..7fe4b7cac53d
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.4.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.4.3-r1.ebuild,v 1.1 2014/06/13 08:30:06 mgorny Exp $
+
+EAPI="5"
+
+inherit autotools-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt static-libs test zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl[${MULTILIB_USEDEP}] )
+ gcrypt? ( dev-libs/libgcrypt:0[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-pkgconfig.patch )
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local myeconfargs=(
+ $(use_with zlib libz)
+ $(usex gcrypt --with-libgcrypt --with-openssl)
+ )
+ autotools-utils_src_configure
+}