summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-14 10:48:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-14 10:48:02 +0000
commit00ff4b485f89c1068de085dd0ed20577e64c5657 (patch)
treea7eef88b0f61b4807bf8ea62414695fd22872987 /net-libs/libtorrent
parentversion bump, thanks armin76 (diff)
downloadgentoo-2-00ff4b485f89c1068de085dd0ed20577e64c5657.tar.gz
gentoo-2-00ff4b485f89c1068de085dd0ed20577e64c5657.tar.bz2
gentoo-2-00ff4b485f89c1068de085dd0ed20577e64c5657.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.10.23
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.2.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 68308b36ef14..440cbffaf1b9 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.67 2006/09/09 12:22:30 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.68 2006/09/14 10:48:02 flameeyes Exp $
+
+*libtorrent-0.10.2 (14 Sep 2006)
+
+ 14 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +libtorrent-0.10.2.ebuild:
+ Version bump.
09 Sep 2006; Torsten Veller <tove@gentoo.org> libtorrent-0.10.0.ebuild:
Stable on x86 (#146845)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.10.2 b/net-libs/libtorrent/files/digest-libtorrent-0.10.2
new file mode 100644
index 000000000000..4eee44872738
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.10.2
@@ -0,0 +1,3 @@
+MD5 99f1daa0f6ce0aa8d53745c494df9b36 libtorrent-0.10.2.tar.gz 453071
+RMD160 51016db461ff1a3d4b2ff952c94f35981ce0004e libtorrent-0.10.2.tar.gz 453071
+SHA256 b3bd1dcc0de3dfdec4a2d6f7012d126875e166330ff9d399927b468fde7ae5d1 libtorrent-0.10.2.tar.gz 453071
diff --git a/net-libs/libtorrent/libtorrent-0.10.2.ebuild b/net-libs/libtorrent/libtorrent-0.10.2.ebuild
new file mode 100644
index 000000000000..7530124e0d60
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.2.ebuild,v 1.1 2006/09/14 10:48:02 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}