summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2008-07-11 21:04:42 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2008-07-11 21:04:42 +0000
commit2c8293f385efefe5f83956d65c69bc923109e7db (patch)
tree43a2c4c95563b210b7abf5a0666faa5773a38ed2 /net-libs/libupnp
parentVersion bump. (diff)
downloadgentoo-2-2c8293f385efefe5f83956d65c69bc923109e7db.tar.gz
gentoo-2-2c8293f385efefe5f83956d65c69bc923109e7db.tar.bz2
gentoo-2-2c8293f385efefe5f83956d65c69bc923109e7db.zip
Bumping to version 1.6.6
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 i686)
Diffstat (limited to 'net-libs/libupnp')
-rw-r--r--net-libs/libupnp/ChangeLog8
-rw-r--r--net-libs/libupnp/libupnp-1.6.6.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/net-libs/libupnp/ChangeLog b/net-libs/libupnp/ChangeLog
index ec12a66e57bc..fea59d522355 100644
--- a/net-libs/libupnp/ChangeLog
+++ b/net-libs/libupnp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libupnp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.16 2008/05/12 15:58:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.17 2008/07/11 21:04:42 gurligebis Exp $
+
+*libupnp-1.6.6 (11 Jul 2008)
+
+ 11 Jul 2008; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ +libupnp-1.6.6.ebuild:
+ Bumping to version 1.6.6
12 May 2008; Markus Rothe <corsair@gentoo.org> libupnp-1.6.5.ebuild:
Stable on ppc64
diff --git a/net-libs/libupnp/libupnp-1.6.6.ebuild b/net-libs/libupnp/libupnp-1.6.6.ebuild
new file mode 100644
index 000000000000..17e978471af8
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/libupnp-1.6.6.ebuild,v 1.1 2008/07/11 21:04:42 gurligebis Exp $
+
+WANT_AUTOMAKE=1.9
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ AT_M4DIR="m4" eautoreconf
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh
+}
+
+src_compile() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf \
+ $(use_enable debug) \
+ --without-docdir \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin upnp/sample/upnp_tv_{ctrlpt,device,combo}
+ dodoc NEWS README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "Please remember to run revdep-rebuild when upgrading"
+ ewarn "from libupnp 1.4.x to libupnp 1.6.x , so packages"
+ ewarn "gets linked with the new library."
+ ewarn ""
+ ewarn "The revdep-rebuild script is part of the"
+ ewarn "app-portage/gentoolkit package."
+ ebeep
+}