summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-04-05 13:27:39 +0000
committerMarinus Schraal <foser@gentoo.org>2006-04-05 13:27:39 +0000
commit4917ca973cd76321cdf8c8479e7b9608cacc34f6 (patch)
tree751e78211cf4561c414d64d14d7dee5fd271c459 /net-libs/loudmouth/loudmouth-1.0.2.ebuild
parentRe-apply fixes for modular X setups, libxslt dependency and ~x86-fbsd keyword. (diff)
downloadgentoo-2-4917ca973cd76321cdf8c8479e7b9608cacc34f6.tar.gz
gentoo-2-4917ca973cd76321cdf8c8479e7b9608cacc34f6.tar.bz2
gentoo-2-4917ca973cd76321cdf8c8479e7b9608cacc34f6.zip
bugfix release
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-libs/loudmouth/loudmouth-1.0.2.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-1.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-1.0.2.ebuild b/net-libs/loudmouth/loudmouth-1.0.2.ebuild
new file mode 100644
index 000000000000..cf26932ff3f2
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.0.2.ebuild,v 1.1 2006/04/05 13:27:39 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://loudmouth.imendio.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc ssl debug"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+
+ G2CONF="$(use_with ssl) \
+ $(use_enable debug)\
+ $(use_enable doc gtk-doc)"
+
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}/loudmouth
+ # fix building sans ssl
+ epatch ${FILESDIR}/${P}-build_without_ssl.patch
+
+}