summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-04 22:56:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-04 22:56:45 +0000
commit612a32d625f04eb67ebbfa1270b36627c87d61b1 (patch)
tree2e38e1e04693f38249b6cc5339d7bd01b57b646c /net-libs/loudmouth
parentamd64/x86 stable, bug #249435 (diff)
downloadgentoo-2-612a32d625f04eb67ebbfa1270b36627c87d61b1.tar.gz
gentoo-2-612a32d625f04eb67ebbfa1270b36627c87d61b1.tar.bz2
gentoo-2-612a32d625f04eb67ebbfa1270b36627c87d61b1.zip
Bump to 1.4.3. Allow building against system libasyncns, bug #236844.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog8
-rw-r--r--net-libs/loudmouth/files/loudmouth-1.4.3-asyncns-system.patch83
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3.ebuild53
3 files changed, 143 insertions, 1 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index fef26db42cac..79a4f48c2680 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.78 2008/10/23 09:48:03 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.79 2008/12/04 22:56:45 eva Exp $
+
+*loudmouth-1.4.3 (04 Dec 2008)
+
+ 04 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/loudmouth-1.4.3-asyncns-system.patch, +loudmouth-1.4.3.ebuild:
+ Bump to 1.4.3. Allow building against system libasyncns, bug #236844.
*loudmouth-1.4.2-r1 (23 Oct 2008)
diff --git a/net-libs/loudmouth/files/loudmouth-1.4.3-asyncns-system.patch b/net-libs/loudmouth/files/loudmouth-1.4.3-asyncns-system.patch
new file mode 100644
index 000000000000..9cf5345e558d
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-1.4.3-asyncns-system.patch
@@ -0,0 +1,83 @@
+diff --git a/configure.ac b/configure.ac
+index 9369e55..17a9e1d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -199,19 +199,31 @@ AM_CONDITIONAL(USE_GNUTLS, test x$enable_ssl = xGnuTLS)
+ dnl +-------------------------------------------------------------------+
+ dnl | Checking for libasyncns |
+ dnl +-------------------------------------------------------------------+
+-AC_ARG_WITH(asyncns, [ --with-asyncns=yes/no define whether to use libasyncns, default=no],
+- ac_asyncns=$withval,
+- ac_asyncns=no
+- )
++AC_ARG_WITH(asyncns,
++ AS_HELP_STRING([--with-asyncns],
++ [define whether to use libasyncns, @<:@default=no@:>@ (internal/system/no)]),
++ ac_asyncns=$withval,
++ ac_asyncns=no)
+
+ enable_asyncns=no
++have_asyncns_system=no
+ if test x$ac_asyncns != xno; then
+ enable_asyncns=yes
+ AC_DEFINE(HAVE_ASYNCNS, 1, [Whether to use libasyncns])
++
++ if test x$ac_asyncns = xsystem; then
++ PKG_CHECK_MODULES(ASYNCNS, [libasyncns >= 0.3],
++ [have_asyncns_system=yes],
++ [have_asyncns_system=no])
++ fi
+ else
+ echo "Not using asynchronous dns lookups"
+ fi
+
++AC_SUBST(ASYNCNS_CFLAGS)
++AC_SUBST(ASYNCNS_LIBS)
++AM_CONDITIONAL(USE_SYSTEM_ASYNCNS, test x$have_asyncns_system = xyes)
++
+ dnl +-------------------------------------------------------------------+
+ dnl | Checking for Linux TCP/IP stack |
+ dnl +-------------------------------------------------------------------+
+diff --git a/loudmouth/Makefile.am b/loudmouth/Makefile.am
+index f73aa0c..e308e1c 100644
+--- a/loudmouth/Makefile.am
++++ b/loudmouth/Makefile.am
+@@ -6,6 +6,7 @@ AM_CPPFLAGS = \
+ -I. \
+ -I$(top_srcdir) \
+ $(LOUDMOUTH_CFLAGS) \
++ $(ASYNCNS_CFLAGS) \
+ $(LIBIDN_CFLAGS) \
+ -DLM_COMPILATION \
+ -DRUNTIME_ENDIAN \
+@@ -51,8 +52,6 @@ libloudmouth_1_la_SOURCES = \
+ lm-sock.c \
+ lm-socket.c \
+ lm-socket.h \
+- asyncns.c \
+- asyncns.h \
+ lm-sasl.c \
+ lm-sasl.h \
+ md5.c \
+@@ -61,6 +60,13 @@ libloudmouth_1_la_SOURCES = \
+ base64.h \
+ $(NULL)
+
++if ! USE_SYSTEM_ASYNCNS
++libloudmouth_1_la_SOURCES += \
++ asyncns.c \
++ asyncns.h \
++ $(NULL)
++endif
++
+ libloudmouthinclude_HEADERS = \
+ lm-connection.h \
+ lm-error.h \
+@@ -75,6 +81,7 @@ libloudmouthinclude_HEADERS = \
+
+ libloudmouth_1_la_LIBADD = \
+ $(LOUDMOUTH_LIBS) \
++ $(ASYNCNS_LIBS) \
+ $(LIBIDN_LIBS) \
+ -lresolv
+
diff --git a/net-libs/loudmouth/loudmouth-1.4.3.ebuild b/net-libs/loudmouth/loudmouth-1.4.3.ebuild
new file mode 100644
index 000000000000..d8bfd64e03fb
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3.ebuild,v 1.1 2008/12/04 22:56:45 eva Exp $
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="asyncns doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )
+ asyncns? ( net-libs/libasyncns )"
+# FIXME:
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+
+ if use asyncns; then
+ G2CONF="${G2CONF} --with-asyncns=system"
+ else
+ G2CONF="${G2CONF} --without-asyncns"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use system libasyncns, bug #236844
+ epatch "${FILESDIR}/${P}-asyncns-system.patch"
+
+ eautoreconf
+}