summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-21 02:55:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-21 02:55:43 +0000
commitda53a012cf237a8e4d2368109dab57859ac7cbad (patch)
treef478476f5edf930341422b9212284b83ed4b9d7b /net-libs/nodejs
parentBump to 2.0_alpha, not yet working properly, thus no keywords (diff)
downloadgentoo-2-da53a012cf237a8e4d2368109dab57859ac7cbad.tar.gz
gentoo-2-da53a012cf237a8e4d2368109dab57859ac7cbad.tar.bz2
gentoo-2-da53a012cf237a8e4d2368109dab57859ac7cbad.zip
Bump for #488624
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog11
-rw-r--r--net-libs/nodejs/nodejs-0.10.17.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.18.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.19.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.21.ebuild (renamed from net-libs/nodejs/nodejs-0.10.20.ebuild)2
-rw-r--r--net-libs/nodejs/nodejs-0.8.23.ebuild71
-rw-r--r--net-libs/nodejs/nodejs-0.8.26.ebuild (renamed from net-libs/nodejs/nodejs-0.8.21.ebuild)2
7 files changed, 12 insertions, 278 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index bfeb19db6c73..144d402f9da6 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.107 2013/10/01 01:31:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.108 2013/10/21 02:55:43 patrick Exp $
+
+*nodejs-0.10.21 (21 Oct 2013)
+*nodejs-0.8.26 (21 Oct 2013)
+
+ 21 Oct 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.21.ebuild,
+ +nodejs-0.8.26.ebuild, -nodejs-0.10.17.ebuild, -nodejs-0.10.18.ebuild,
+ -nodejs-0.10.19.ebuild, -nodejs-0.10.20.ebuild, -nodejs-0.8.21.ebuild,
+ -nodejs-0.8.23.ebuild:
+ Bump for #488624
*nodejs-0.10.20 (01 Oct 2013)
diff --git a/net-libs/nodejs/nodejs-0.10.17.ebuild b/net-libs/nodejs/nodejs-0.10.17.ebuild
deleted file mode 100644
index 775698b87417..000000000000
--- a/net-libs/nodejs/nodejs-0.10.17.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.17.ebuild,v 1.5 2013/09/22 06:43:53 ago Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.18.ebuild b/net-libs/nodejs/nodejs-0.10.18.ebuild
deleted file mode 100644
index dc697d8f0d1d..000000000000
--- a/net-libs/nodejs/nodejs-0.10.18.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.18.ebuild,v 1.3 2013/09/12 20:59:15 mgorny Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.19.ebuild b/net-libs/nodejs/nodejs-0.10.19.ebuild
deleted file mode 100644
index 0098e2ec45c0..000000000000
--- a/net-libs/nodejs/nodejs-0.10.19.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.19.ebuild,v 1.1 2013/09/25 02:42:49 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm +snapshot"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
- ! use snapshot && myconf="${myconf} --without-snapshot"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.20.ebuild b/net-libs/nodejs/nodejs-0.10.21.ebuild
index 6a1dd14c61eb..c53438a81894 100644
--- a/net-libs/nodejs/nodejs-0.10.20.ebuild
+++ b/net-libs/nodejs/nodejs-0.10.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.20.ebuild,v 1.1 2013/10/01 01:31:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.21.ebuild,v 1.1 2013/10/21 02:55:43 patrick Exp $
EAPI=5
diff --git a/net-libs/nodejs/nodejs-0.8.23.ebuild b/net-libs/nodejs/nodejs-0.8.23.ebuild
deleted file mode 100644
index 5bf2f0f6b309..000000000000
--- a/net-libs/nodejs/nodejs-0.8.23.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.8.23.ebuild,v 1.1 2013/04/09 03:46:36 patrick Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="2"
-
-inherit python eutils multilib pax-utils
-
-# omgwtf
-RESTRICT="test"
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE=""
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
- python_convert_shebangs 2 tools/node-waf || die
-}
-
-src_configure() {
- # this is an autotools lookalike confuserator
- ./configure --prefix="${EPREFIX}"/usr --openssl-use-sys --shared-zlib || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- local MYLIB=$(get_libdir)
- mkdir -p "${ED}"/usr/include/node
- mkdir -p "${ED}"/usr/bin
- mkdir -p "${ED}"/usr/"${MYLIB}"/node_modules/npm
- mkdir -p "${ED}"/usr/"${MYLIB}"/node
- cp 'src/eio-emul.h' 'src/ev-emul.h' 'src/node.h' 'src/node_buffer.h' 'src/node_object_wrap.h' 'src/node_version.h' "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/uv/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp -R deps/v8/include/* "${ED}"/usr/include/node || die "Failed to copy stuff"
- cp 'out/Release/node' "${ED}"/usr/bin/node || die "Failed to copy stuff"
- cp -R deps/npm/* "${ED}"/usr/"${MYLIB}"/node_modules/npm || die "Failed to copy stuff"
- cp -R tools/wafadmin "${ED}"/usr/"${MYLIB}"/node/ || die "Failed to copy stuff"
- cp 'tools/node-waf' "${ED}"/usr/bin/ || die "Failed to copy stuff"
-
- # now add some extra stupid just because we can
- # needs to be a symlink because of hardcoded paths ... no es bueno!
- dosym /usr/"${MYLIB}"/node_modules/npm/bin/npm-cli.js /usr/bin/npm
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- emake test || die
-}
diff --git a/net-libs/nodejs/nodejs-0.8.21.ebuild b/net-libs/nodejs/nodejs-0.8.26.ebuild
index 45433a01601a..03cd8fc328ad 100644
--- a/net-libs/nodejs/nodejs-0.8.21.ebuild
+++ b/net-libs/nodejs/nodejs-0.8.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.8.21.ebuild,v 1.1 2013/03/06 03:43:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.8.26.ebuild,v 1.1 2013/10/21 02:55:43 patrick Exp $
EAPI=5