summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-01-04 20:35:06 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-01-04 20:35:06 +0000
commit384eeddf8b4f0054dc270c40ea03424aa37b2bdd (patch)
tree835d4f5b8018f162a7e33d6a75c9bebfd9a1d410 /net-libs/opal
parentMarking ispell-pt-br-2.4-r3 ppc for bug 393731 (diff)
downloadgentoo-2-384eeddf8b4f0054dc270c40ea03424aa37b2bdd.tar.gz
gentoo-2-384eeddf8b4f0054dc270c40ea03424aa37b2bdd.tar.bz2
gentoo-2-384eeddf8b4f0054dc270c40ea03424aa37b2bdd.zip
Fix static libs, fix ldflags for plugins (bug 397681), and fix ptlib dep for vxml
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/opal')
-rw-r--r--net-libs/opal/ChangeLog9
-rw-r--r--net-libs/opal/files/opal-3.6.8-lid-plugins-ldflags.patch40
-rw-r--r--net-libs/opal/opal-3.6.8-r2.ebuild20
3 files changed, 61 insertions, 8 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index f2fcd2350b57..73ce6ec8fdfd 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.73 2011/05/24 13:30:06 pva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.74 2012/01/04 20:35:06 nirbheek Exp $
+
+ 04 Jan 2012; Nirbheek Chauhan <nirbheek@gentoo.org> opal-3.6.8-r2.ebuild,
+ +files/opal-3.6.8-lid-plugins-ldflags.patch:
+ Fix static libs, fix ldflags for plugins (bug 397681), and fix ptlib dep for
+ vxml
24 May 2011; Peter Volkov <pva@gentoo.org> opal-3.6.8-r2.ebuild:
Update another occurence of media-video/ffmpeg to virtual/ffmpeg.
diff --git a/net-libs/opal/files/opal-3.6.8-lid-plugins-ldflags.patch b/net-libs/opal/files/opal-3.6.8-lid-plugins-ldflags.patch
new file mode 100644
index 000000000000..071c7f066e65
--- /dev/null
+++ b/net-libs/opal/files/opal-3.6.8-lid-plugins-ldflags.patch
@@ -0,0 +1,40 @@
+Fix LID plugin ldflags
+
+https://bugs.gentoo.org/397681
+
+--- plugins/LID/CAPI/Makefile.in
++++ plugins/LID/CAPI/Makefile.in
+@@ -67,7 +67,7 @@
+ OBJECTS = $(addprefix $(OBJDIR)/,$(patsubst %.cxx,%.o,$(notdir $(SRCS))))
+
+ $(PLUGIN): $(OBJECTS)
+- $(Q_LD)$(CC) $(LDSO)$(SONAME) -o $@ $^ $(EXTRALIBS)
++ $(Q_LD)$(CC) $(LDFLAGS) $(LDSO)$(SONAME) -o $@ $^ $(EXTRALIBS)
+
+ install:
+ mkdir -p $(DESTDIR)$(libdir)/$(LID_PLUGIN_DIR)
+--- plugins/LID/IxJ/Makefile.in
++++ plugins/LID/IxJ/Makefile.in
+@@ -72,7 +72,7 @@
+ OBJECTS = $(addprefix $(OBJDIR)/,$(patsubst %.cxx,%.o,$(notdir $(SRCS))))
+
+ $(PLUGIN): $(OBJECTS)
+- $(Q_LD)$(CC) $(LDSO)$(SONAME) -o $@ $^ $(EXTRALIBS)
++ $(Q_LD)$(CC) $(LDFLAGS) $(LDSO)$(SONAME) -o $@ $^ $(EXTRALIBS)
+
+ install:
+ mkdir -p $(DESTDIR)$(libdir)/$(LID_PLUGIN_DIR)
+--- plugins/LID/VPB/Makefile.in
++++ plugins/LID/VPB/Makefile.in
+@@ -79,9 +79,9 @@
+
+ ifeq (solaris,$(findstring solaris,$(target_os)))
+
+- $(Q_LD)$(CC) $(LDSO) $@ -o $@ $^ $(EXTRALIBS)
++ $(Q_LD)$(CC) $(LDFLAGS) $(LDSO) $@ -o $@ $^ $(EXTRALIBS)
+ else
+- $(Q_LD)$(CC) $(LDSO) -o $@ $^ $(EXTRALIBS)
++ $(Q_LD)$(CC) $(LDFLAGS) $(LDSO) -o $@ $^ $(EXTRALIBS)
+
+ endif
+
diff --git a/net-libs/opal/opal-3.6.8-r2.ebuild b/net-libs/opal/opal-3.6.8-r2.ebuild
index 52afa40387af..353c59f6eacb 100644
--- a/net-libs/opal/opal-3.6.8-r2.ebuild
+++ b/net-libs/opal/opal-3.6.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.8-r2.ebuild,v 1.2 2011/05/24 13:30:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.8-r2.ebuild,v 1.3 2012/01/04 20:35:06 nirbheek Exp $
EAPI="4"
@@ -16,8 +16,8 @@ LICENSE="MPL-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="+audio capi celt debug doc dtmf examples fax ffmpeg h224 h281 h323 iax
-ilbc ipv6 ivr ixj java ldap lid +plugins sbc sip sipim srtp ssl stats swig
-theora +video vpb vxml wav x264 x264-static xml"
+ilbc ipv6 ivr ixj java ldap lid +plugins sbc sip sipim srtp ssl static-libs
+stats swig theora +video vpb vxml wav x264 x264-static xml"
REQUIRED_USE="x264-static? ( x264 )
h281? ( h224 )"
@@ -26,7 +26,7 @@ RDEPEND=">=net-libs/ptlib-2.6.6[stun,debug=,audio?,dtmf?,ipv6?,ldap?,ssl?,video?
>=media-libs/speex-1.2_beta
fax? ( net-libs/ptlib[asn] )
h323? ( net-libs/ptlib[asn] )
- ivr? ( net-libs/ptlib[xml,vxml] )
+ ivr? ( net-libs/ptlib[http,xml,vxml] )
java? ( >=virtual/jre-1.4 )
plugins? (
media-sound/gsm
@@ -39,7 +39,8 @@ RDEPEND=">=net-libs/ptlib-2.6.6[stun,debug=,audio?,dtmf?,ipv6?,ldap?,ssl?,video?
theora? ( media-libs/libtheora )
x264? ( virtual/ffmpeg
media-libs/x264 ) )
- srtp? ( net-libs/libsrtp )"
+ srtp? ( net-libs/libsrtp )
+ vxml? ( net-libs/ptlib[http,vxml] )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
>=sys-devel/gcc-3
@@ -88,6 +89,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-build-fix.patch #343041
epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-lid-plugins-ldflags.patch #397681
# h224 really needs h323 ?
# TODO: get a confirmation in ml
@@ -227,6 +229,12 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ # Get rid of static libraries if not requested
+ # There seems to be no easy way to disable this in the build system
+ if ! use static-libs; then
+ rm -v "${D}"/usr/lib*/*.a || die
+ fi
+
if use doc; then
dohtml -r "${WORKDIR}"/html/* docs/* || die "dohtml failed"
fi