summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-03 21:25:00 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-03 21:25:00 +0000
commite9616f1169532fa2689f2df5bcd3218812f71a3b (patch)
tree26497ee56638a3d0c42a9dbe5e27599849bd897f /net-libs/openhbci
parentmoved xft usage to USE="truetype" test in commonbox.eclass (diff)
downloadgentoo-2-e9616f1169532fa2689f2df5bcd3218812f71a3b.tar.gz
gentoo-2-e9616f1169532fa2689f2df5bcd3218812f71a3b.tar.bz2
gentoo-2-e9616f1169532fa2689f2df5bcd3218812f71a3b.zip
added patch to fix openssl related crashes woth openhbci
Diffstat (limited to 'net-libs/openhbci')
-rw-r--r--net-libs/openhbci/ChangeLog9
-rw-r--r--net-libs/openhbci/Manifest5
-rw-r--r--net-libs/openhbci/files/digest-openhbci-0.9.9-r11
-rw-r--r--net-libs/openhbci/files/openhbci-0.9.9-rsa.patch25
-rw-r--r--net-libs/openhbci/openhbci-0.9.9-r1.ebuild30
5 files changed, 68 insertions, 2 deletions
diff --git a/net-libs/openhbci/ChangeLog b/net-libs/openhbci/ChangeLog
index c3dd73bfb18a..20f186b5e77e 100644
--- a/net-libs/openhbci/ChangeLog
+++ b/net-libs/openhbci/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/openhbci
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openhbci/ChangeLog,v 1.2 2003/04/29 10:16:12 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openhbci/ChangeLog,v 1.3 2003/06/03 21:24:47 liquidx Exp $
+
+*openhbci-0.9.9-r1 (03 Jun 2003)
+
+ 03 Jun 2003; Alastair Tse <liquidx@gentoo.org> openhbci-0.9.9-r1.ebuild,
+ files/openhbci-0.9.9-rsa.patch:
+ added added patch to fix crashes with openssl 0.9.6h. thanks to Andreas Grüner
+ <andreas.gruener@tiscali.de> (#21294)
*openhbci-0.9.9 (28 Apr 2003)
diff --git a/net-libs/openhbci/Manifest b/net-libs/openhbci/Manifest
index 8a0cafcca64e..0b4a7b2ec646 100644
--- a/net-libs/openhbci/Manifest
+++ b/net-libs/openhbci/Manifest
@@ -1,3 +1,6 @@
+MD5 01cc29ea6a11546189c86d73a2d96584 ChangeLog 734
+MD5 c1c0ac33890f378962a67d6879a2321b openhbci-0.9.9-r1.ebuild 789
MD5 6e9d7073bce881876f57bbaa89c8a2ac openhbci-0.9.9.ebuild 720
-MD5 8365540ba2687df1b6791155edfe35a6 ChangeLog 468
MD5 67fa7d943ed9c7c7e3282e8421d53530 files/digest-openhbci-0.9.9 66
+MD5 c4963be51c5491888d4e73f705e7188c files/openhbci-0.9.9-rsa.patch 1040
+MD5 67fa7d943ed9c7c7e3282e8421d53530 files/digest-openhbci-0.9.9-r1 66
diff --git a/net-libs/openhbci/files/digest-openhbci-0.9.9-r1 b/net-libs/openhbci/files/digest-openhbci-0.9.9-r1
new file mode 100644
index 000000000000..d99900e7af7d
--- /dev/null
+++ b/net-libs/openhbci/files/digest-openhbci-0.9.9-r1
@@ -0,0 +1 @@
+MD5 59fe3c9ed912c310608d9eea10b41543 openhbci-0.9.9.tar.gz 590958
diff --git a/net-libs/openhbci/files/openhbci-0.9.9-rsa.patch b/net-libs/openhbci/files/openhbci-0.9.9-rsa.patch
new file mode 100644
index 000000000000..691b8b7138fd
--- /dev/null
+++ b/net-libs/openhbci/files/openhbci-0.9.9-rsa.patch
@@ -0,0 +1,25 @@
+--- openhbci-0.9.9/src/openhbci/core/rsakey.cpp 2003-05-07 21:20:24.000000000 +0100
++++ openhbci-0.9.9-new/src/openhbci/core/rsakey.cpp 2003-05-07 21:23:32.000000000 +0100
+@@ -336,13 +336,18 @@
+ myBIGNUM = BN_new(); \
+ myBIGNUM = BN_bin2bn((unsigned char*) tstring.data(), tstring.length(), myBIGNUM); \
+ rsaStruct->tstring = myBIGNUM; }
++
++ // since openssl uses blinding, we have to set 'e' even if this is the
++ // private key
++ BIGNUM *myExponent = BN_new();
++ BN_set_word(myExponent,DEFAULT_EXPONENT);
++ rsaStruct->e = myExponent;
++
+ if (isPublicKey()) {
+ BIGNUM *myModulus = BN_new();
+- BIGNUM *myExponent = BN_new();
+- BN_set_word(myExponent,DEFAULT_EXPONENT);
+- myModulus = BN_bin2bn((unsigned char*) modulus.data(), modulus.length(), myModulus);
++ myModulus = BN_bin2bn((unsigned char*) modulus.data(),
++ modulus.length(), myModulus);
+ rsaStruct->n = myModulus;
+- rsaStruct->e = myExponent;
+ } else {
+ BIGNUM *myBIGNUM;
+ NEXT(n);
diff --git a/net-libs/openhbci/openhbci-0.9.9-r1.ebuild b/net-libs/openhbci/openhbci-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..9c0f3fe42904
--- /dev/null
+++ b/net-libs/openhbci/openhbci-0.9.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openhbci/openhbci-0.9.9-r1.ebuild,v 1.1 2003/06/03 21:24:47 liquidx Exp $
+
+DESCRIPTION="Implementation of the HBCI protocol used by some banks"
+HOMEPAGE="http://openhbci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openhbci/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.6
+ >=sys-libs/libchipcard-0.8"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-rsa.patch
+}
+
+src_compile() {
+ econf --with-chipcard=/usr || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS README TODO
+}