summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-03-30 10:18:52 +0000
committerPacho Ramos <pacho@gentoo.org>2014-03-30 10:18:52 +0000
commit08bf371ef411f99bd1638b91e4606e30b2032945 (patch)
treee61652eac133a5f42b54a85ea5eee86b87085ca2 /net-libs/openslp
parentfix symbol lookup error on prefix, wrt bug #473696 (diff)
downloadgentoo-2-08bf371ef411f99bd1638b91e4606e30b2032945.tar.gz
gentoo-2-08bf371ef411f99bd1638b91e4606e30b2032945.tar.bz2
gentoo-2-08bf371ef411f99bd1638b91e4606e30b2032945.zip
Add unit file (#485028 by Reuben Martin)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/openslp')
-rw-r--r--net-libs/openslp/ChangeLog10
-rw-r--r--net-libs/openslp/files/slpd.service10
-rw-r--r--net-libs/openslp/openslp-1.2.1-r3.ebuild42
-rw-r--r--net-libs/openslp/openslp-2.0.0.ebuild7
4 files changed, 64 insertions, 5 deletions
diff --git a/net-libs/openslp/ChangeLog b/net-libs/openslp/ChangeLog
index 89b849318247..e1d401811f5e 100644
--- a/net-libs/openslp/ChangeLog
+++ b/net-libs/openslp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/openslp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/ChangeLog,v 1.60 2013/08/15 02:47:15 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/ChangeLog,v 1.61 2014/03/30 10:18:52 pacho Exp $
+
+*openslp-1.2.1-r3 (30 Mar 2014)
+
+ 30 Mar 2014; Pacho Ramos <pacho@gentoo.org> +files/slpd.service,
+ +openslp-1.2.1-r3.ebuild, openslp-2.0.0.ebuild:
+ Add unit file (#485028 by Reuben Martin)
15 Aug 2013; Patrick Lauer <patrick@gentoo.org> openslp-2.0.0.ebuild:
Fixing src_unpack / src_prepare
diff --git a/net-libs/openslp/files/slpd.service b/net-libs/openslp/files/slpd.service
new file mode 100644
index 000000000000..ab5c02f3b773
--- /dev/null
+++ b/net-libs/openslp/files/slpd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Service Location Protocol
+After=network-online.target
+
+[Service]
+ExecStart=/usr/sbin/slpd -l /var/log/slpd.log -d
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=network.target
diff --git a/net-libs/openslp/openslp-1.2.1-r3.ebuild b/net-libs/openslp/openslp-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..adad1855d01c
--- /dev/null
+++ b/net-libs/openslp/openslp-1.2.1-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-1.2.1-r3.ebuild,v 1.1 2014/03/30 10:18:52 pacho Exp $
+
+inherit eutils autotools systemd
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-fbsd.patch
+ epatch "${FILESDIR}"/${P}-fixoverflow.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf || die
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+ rm -rf "${D}"/usr/doc
+ dohtml -r .
+ newinitd "${FILESDIR}"/slpd-init slpd
+ systemd_dounit "${FILESDIR}"/slpd.service
+}
diff --git a/net-libs/openslp/openslp-2.0.0.ebuild b/net-libs/openslp/openslp-2.0.0.ebuild
index b5a146b7c8e1..209540b11d9e 100644
--- a/net-libs/openslp/openslp-2.0.0.ebuild
+++ b/net-libs/openslp/openslp-2.0.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-2.0.0.ebuild,v 1.2 2013/08/15 02:47:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-2.0.0.ebuild,v 1.3 2014/03/30 10:18:52 pacho Exp $
EAPI=5
-inherit eutils autotools
+inherit eutils autotools systemd
DESCRIPTION="An open-source implementation of Service Location Protocol"
HOMEPAGE="http://www.openslp.org/"
@@ -30,4 +30,5 @@ src_install() {
rm -rfv "${D}"/usr/doc
dohtml -r .
newinitd "${FILESDIR}"/slpd-init slpd
+ systemd_dounit "${FILESDIR}"/slpd.service
}