summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-28 01:46:14 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-28 01:46:14 +0000
commitf74a821bb4bdc4256ca2e929fb996a3f2e73e751 (patch)
tree841d9cef3ff7dd8c9dd9065c8c9a811239654e4c /net-libs/rest
parentAdd new snapshot (diff)
downloadgentoo-2-f74a821bb4bdc4256ca2e929fb996a3f2e73e751.tar.gz
gentoo-2-f74a821bb4bdc4256ca2e929fb996a3f2e73e751.tar.bz2
gentoo-2-f74a821bb4bdc4256ca2e929fb996a3f2e73e751.zip
Remove incorrect disabling of test, it seems to pass now
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rest')
-rw-r--r--net-libs/rest/ChangeLog6
-rw-r--r--net-libs/rest/files/rest-0.7.10-disable-broken-test.patch21
-rw-r--r--net-libs/rest/rest-0.7.10.ebuild13
3 files changed, 7 insertions, 33 deletions
diff --git a/net-libs/rest/ChangeLog b/net-libs/rest/ChangeLog
index 31723dad03cf..6dbc513b6791 100644
--- a/net-libs/rest/ChangeLog
+++ b/net-libs/rest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.1 2011/04/24 12:02:30 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.2 2011/04/28 01:46:14 nirbheek Exp $
+
+ 28 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> rest-0.7.10.ebuild,
+ -files/rest-0.7.10-disable-broken-test.patch:
+ Remove incorrect disabling of test, it seems to pass now
*rest-0.7.10 (24 Apr 2011)
diff --git a/net-libs/rest/files/rest-0.7.10-disable-broken-test.patch b/net-libs/rest/files/rest-0.7.10-disable-broken-test.patch
deleted file mode 100644
index 32478540d3a2..000000000000
--- a/net-libs/rest/files/rest-0.7.10-disable-broken-test.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- tests/Makefile.am
-+++ tests/Makefile.am
-@@ -1,6 +1,6 @@
- TESTS = proxy proxy-continuous threaded oauth oauth-async oauth2 flickr lastfm xml custom-serialize
- # TODO: fix this test case
--XFAIL_TESTS = xml
-+XFAIL_TESTS = xml custom-serialize
-
- AM_CPPFLAGS = $(SOUP_CFLAGS) -I$(top_srcdir) $(GCOV_CFLAGS)
- AM_LDFLAGS = $(SOUP_LIBS) $(GCOV_LDFLAGS) \
---- tests/Makefile.in
-+++ tests/Makefile.in
-@@ -37,7 +37,7 @@
- oauth$(EXEEXT) oauth-async$(EXEEXT) oauth2$(EXEEXT) \
- flickr$(EXEEXT) lastfm$(EXEEXT) xml$(EXEEXT) \
- custom-serialize$(EXEEXT)
--XFAIL_TESTS = xml$(EXEEXT)
-+XFAIL_TESTS = xml$(EXEEXT) custom-serialize$(EXEEXT)
- check_PROGRAMS = $(am__EXEEXT_1)
- subdir = tests
- DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
diff --git a/net-libs/rest/rest-0.7.10.ebuild b/net-libs/rest/rest-0.7.10.ebuild
index 26e854d2c3ca..73ead263c87f 100644
--- a/net-libs/rest/rest-0.7.10.ebuild
+++ b/net-libs/rest/rest-0.7.10.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.10.ebuild,v 1.1 2011/04/24 12:02:30 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.10.ebuild,v 1.2 2011/04/28 01:46:14 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils gnome2 virtualx
+inherit gnome2 virtualx
DESCRIPTION="Helper library for RESTful services"
HOMEPAGE="http://git.gnome.org/browse/librest"
@@ -38,15 +38,6 @@ pkg_setup() {
DOCS="AUTHORS NEWS README"
}
-src_prepare() {
- # Conditional patching because the test passes without libsoup
- if use test && use gnome; then
- # https://bugs.meego.com/show_bug.cgi?id=16650
- epatch "${FILESDIR}/${P}-disable-broken-test.patch"
- fi
- gnome2_src_prepare
-}
-
src_test() {
# Tests need dbus
Xemake check || die