summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-10 11:13:50 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-10 11:13:50 +0000
commit37c294c07a90291849d25afdce0093395dec2f54 (patch)
treeda36b747696418de67de819c38961f65b007dd23 /net-libs/socket++/socket++-1.12.12.ebuild
parentsome dosemu cleanups and fixes (Manifest recommit) (diff)
downloadgentoo-2-37c294c07a90291849d25afdce0093395dec2f54.tar.gz
gentoo-2-37c294c07a90291849d25afdce0093395dec2f54.tar.bz2
gentoo-2-37c294c07a90291849d25afdce0093395dec2f54.zip
Added IUSE=doc and install HTML docs if set; updated metadata.
Diffstat (limited to 'net-libs/socket++/socket++-1.12.12.ebuild')
-rw-r--r--net-libs/socket++/socket++-1.12.12.ebuild24
1 files changed, 21 insertions, 3 deletions
diff --git a/net-libs/socket++/socket++-1.12.12.ebuild b/net-libs/socket++/socket++-1.12.12.ebuild
index c6c749db4ddd..3aba5f3e992d 100644
--- a/net-libs/socket++/socket++-1.12.12.ebuild
+++ b/net-libs/socket++/socket++-1.12.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12.ebuild,v 1.1 2004/12/16 09:30:28 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12.ebuild,v 1.2 2005/01/10 11:13:50 ka0ttic Exp $
DESCRIPTION="C++ Socket Library"
HOMEPAGE="http://www.linuxhacker.at/socketxx/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.linuxhacker.at/linux/downloads/src/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug doc"
DEPEND="=sys-devel/automake-1.7*
=sys-devel/autoconf-2.59*
@@ -26,9 +26,27 @@ src_unpack() {
src_compile() {
econf $(use_enable debug) || die "econf failed"
emake || die "emake failed"
+
+ if use doc ; then
+ cd ${S}/doc
+ einfo "Building HTML documentation"
+ # the 'html' target in both ${S}/Makefile and ${S}/doc/Makefile
+ # do indeed exist (and succeed when run manually), but fail when
+ # 'make html' is done here, so we call makeinfo ourselves.
+ makeinfo --html -I . -o html socket++.texi || die "makeinfo failed"
+ fi
+}
+
+src_test() {
+ cd ${S}/test
+ make check || die "make check failed"
}
src_install() {
make DESTDIR=${D} install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README* THANKS || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
}