summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-30 10:05:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-30 10:05:10 +0000
commit12c734dddcab781d3be3bbb8f80e778918aece21 (patch)
treea980371af3d6d0fe7d72823324edc0e65a990ea7 /net-libs/telepathy-qt4
parentVersion bump (diff)
downloadgentoo-2-12c734dddcab781d3be3bbb8f80e778918aece21.tar.gz
gentoo-2-12c734dddcab781d3be3bbb8f80e778918aece21.tar.bz2
gentoo-2-12c734dddcab781d3be3bbb8f80e778918aece21.zip
Initial commit of telepathy-qt4. Fixes bug #300397
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-qt4')
-rw-r--r--net-libs/telepathy-qt4/ChangeLog11
-rw-r--r--net-libs/telepathy-qt4/metadata.xml5
-rw-r--r--net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild42
3 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/telepathy-qt4/ChangeLog b/net-libs/telepathy-qt4/ChangeLog
new file mode 100644
index 000000000000..c6b0e18d15a4
--- /dev/null
+++ b/net-libs/telepathy-qt4/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-libs/telepathy-qt4
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.1 2010/05/30 10:05:10 hwoarang Exp $
+
+*telepathy-qt4-0.3.4 (30 May 2010)
+
+ 30 May 2010; Markos Chandras <hwoarang@gentoo.org>
+ +telepathy-qt4-0.3.4.ebuild, +metadata.xml:
+ Initial commit of telepathy-qt4. Moved from qting-edge overlay. Fixes bug
+ #300397
+
diff --git a/net-libs/telepathy-qt4/metadata.xml b/net-libs/telepathy-qt4/metadata.xml
new file mode 100644
index 000000000000..3cbebd85b7e2
--- /dev/null
+++ b/net-libs/telepathy-qt4/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>
diff --git a/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild b/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild
new file mode 100644
index 000000000000..b743c63d94a5
--- /dev/null
+++ b/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild,v 1.1 2010/05/30 10:05:10 hwoarang Exp $
+
+PYTHON_DEPEND="2"
+
+EAPI="2"
+inherit versionator python base
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-dbus:4"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ net-libs/telepathy-farsight"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable debug) $(use_enable static)
+}
+
+src_test() {
+ dbus-launch emake -j1 check || die "emake check failed"
+}
+
+src_install() {
+ base_src_install
+ ! use static && rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}