summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-10 21:45:05 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-10 21:45:05 +0000
commita7e13fd440b5facb53972217b3665b021e0b6a88 (patch)
tree8c66ebf24bff1109df1091a47378b74e2503c4b9 /net-libs/udns
parentInitial commit, ebuild by Simon Arlott, see bug #222741. (diff)
downloadgentoo-2-a7e13fd440b5facb53972217b3665b021e0b6a88.tar.gz
gentoo-2-a7e13fd440b5facb53972217b3665b021e0b6a88.tar.bz2
gentoo-2-a7e13fd440b5facb53972217b3665b021e0b6a88.zip
Improve ebuild, changes by Thomas Anderson (gentoofan23).
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-libs/udns')
-rw-r--r--net-libs/udns/ChangeLog6
-rw-r--r--net-libs/udns/udns-0.0.9.ebuild19
2 files changed, 17 insertions, 8 deletions
diff --git a/net-libs/udns/ChangeLog b/net-libs/udns/ChangeLog
index 00a8c00f59bc..c28fcd1f8520 100644
--- a/net-libs/udns/ChangeLog
+++ b/net-libs/udns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/udns
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.1 2008/06/10 21:34:09 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.2 2008/06/10 21:45:05 nelchael Exp $
+
+ 10 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org> udns-0.0.9.ebuild:
+ Improve ebuild, changes by Thomas Anderson (gentoofan23)
+ <gentoofan23@gmail.com>.
*udns-0.0.9 (10 Jun 2008)
diff --git a/net-libs/udns/udns-0.0.9.ebuild b/net-libs/udns/udns-0.0.9.ebuild
index 1f36f4dc504f..ef0c4f35e76e 100644
--- a/net-libs/udns/udns-0.0.9.ebuild
+++ b/net-libs/udns/udns-0.0.9.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.0.9.ebuild,v 1.1 2008/06/10 21:34:09 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.0.9.ebuild,v 1.2 2008/06/10 21:45:05 nelchael Exp $
-inherit eutils multilib
+inherit multilib
-DESCRIPTION="async-capable DNS stub resolver library"
+DESCRIPTION="Async-capable DNS stub resolver library"
HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
SRC_URI="http://www.corpit.ru/mjt/udns/${P/-/_}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="ipv6 static"
# Yes, this doesn't depend on any other library beside "system" set
DEPEND=""
@@ -19,16 +19,21 @@ DEPEND=""
src_compile() {
# Uses non-standard configure script, econf doesn't work
- ./configure || die "configure failed"
- emake staticlib sharedlib || die "make failed"
+ ./configure $(use_enable ipv6) || die "Configure failed"
+ emake sharedlib || die "Shared library compilation failed"
+ if use static; then
+ emake staticlib || die "Static library compilation failed"
+ fi
}
src_install() {
dolib.so libudns.so.0 || die "dolib.so failed"
- dolib.a libudns.a || die "dolib.a failed"
dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so" || die "dosym failed"
+ if use static; then
+ dolib.a libudns.a || die "dolib.a failed"
+ fi
insinto /usr/include
doins udns.h || die "doins failed"