summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-02 18:58:09 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-02 18:58:09 +0000
commitd89c888d0ad11c94c10a4006f45b77316aba48c6 (patch)
treeab7580c7fa3964b34a6d10ed9fefbf55bd0b914d /net-libs/udns
parentapp-office/grisbi: Bump to 0.8.8 (diff)
downloadgentoo-2-d89c888d0ad11c94c10a4006f45b77316aba48c6.tar.gz
gentoo-2-d89c888d0ad11c94c10a4006f45b77316aba48c6.tar.bz2
gentoo-2-d89c888d0ad11c94c10a4006f45b77316aba48c6.zip
Version bump. Respect LDFLAGS, bug #336040 wrt Diego Elio Pettenò.
(Portage version: 2.1.10.20/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/udns')
-rw-r--r--net-libs/udns/ChangeLog8
-rw-r--r--net-libs/udns/files/udns-0.1-respect-LDFLAGS.patch13
-rw-r--r--net-libs/udns/udns-0.1.ebuild43
3 files changed, 63 insertions, 1 deletions
diff --git a/net-libs/udns/ChangeLog b/net-libs/udns/ChangeLog
index b9071e4a7365..1b795f7e21e7 100644
--- a/net-libs/udns/ChangeLog
+++ b/net-libs/udns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/udns
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.17 2011/09/13 18:29:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.18 2011/10/02 18:58:09 pva Exp $
+
+*udns-0.1 (02 Oct 2011)
+
+ 02 Oct 2011; Peter Volkov <pva@gentoo.org> +udns-0.1.ebuild,
+ +files/udns-0.1-respect-LDFLAGS.patch:
+ Version bump. Respect LDFLAGS, bug #336040 wrt Diego Elio Pettenò.
13 Sep 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #225633
diff --git a/net-libs/udns/files/udns-0.1-respect-LDFLAGS.patch b/net-libs/udns/files/udns-0.1-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..c7afaf8192b2
--- /dev/null
+++ b/net-libs/udns/files/udns-0.1-respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2011-10-02 18:48:41 +0000
++++ Makefile.in 2011-10-02 18:50:00 +0000
+@@ -72,7 +72,7 @@
+ sharedlib: $(SOLIBV)
+
+ $(SOLIBV): $(SOBJS)
+- $(CC) -shared -Wl,--soname,$(SOLIBV) -o $@ $(SOBJS)
++ $(CC) $(LDFLAGS) -shared -Wl,--soname,$(SOLIBV) -o $@ $(SOBJS)
+ $(SOLIB): $(SOLIBV)
+ rm -f $@
+ ln -s $(SOLIBV) $@
+
diff --git a/net-libs/udns/udns-0.1.ebuild b/net-libs/udns/udns-0.1.ebuild
new file mode 100644
index 000000000000..cb06cee4ea72
--- /dev/null
+++ b/net-libs/udns/udns-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.1.ebuild,v 1.1 2011/10/02 18:58:09 pva Exp $
+
+EAPI="4"
+inherit eutils multilib
+
+DESCRIPTION="Async-capable DNS stub resolver library"
+HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
+SRC_URI="http://www.corpit.ru/mjt/udns/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="ipv6 static"
+
+# Yes, this doesn't depend on any other library beside "system" set
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.1-respect-LDFLAGS.patch"
+}
+
+src_configure() {
+ # Uses non-standard configure script, econf doesn't work
+ ./configure $(use_enable ipv6) || die "Configure failed"
+}
+
+src_compile() {
+ emake sharedlib
+}
+
+src_install() {
+ dolib.so libudns.so.0 || die "dolib.so failed"
+ dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so" || die "dosym failed"
+
+ insinto /usr/include
+ doins udns.h
+
+ doman udns.3
+ dodoc TODO NOTES
+}