summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-05 15:51:52 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-05 15:51:52 +0000
commite1b800f1499d7122e73900e007cc65cf2bcb7302 (patch)
treebaa13882399ae7956d8462b9440bfea3ee5b8630 /net-libs/udns
parentversion bump to 2.1 (diff)
downloadgentoo-2-e1b800f1499d7122e73900e007cc65cf2bcb7302.tar.gz
gentoo-2-e1b800f1499d7122e73900e007cc65cf2bcb7302.tar.bz2
gentoo-2-e1b800f1499d7122e73900e007cc65cf2bcb7302.zip
Version bump. Respect CC. Install NEWS.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/udns')
-rw-r--r--net-libs/udns/ChangeLog7
-rw-r--r--net-libs/udns/udns-0.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/udns/ChangeLog b/net-libs/udns/ChangeLog
index 391fa6f9b6f4..26298dbb0985 100644
--- a/net-libs/udns/ChangeLog
+++ b/net-libs/udns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/udns
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.25 2012/07/21 02:21:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/ChangeLog,v 1.26 2012/09/05 15:51:52 jer Exp $
+
+*udns-0.2 (05 Sep 2012)
+
+ 05 Sep 2012; Jeroen Roovers <jer@gentoo.org> +udns-0.2.ebuild:
+ Version bump. Respect CC. Install NEWS.
21 Jul 2012; Anthony G. Basile <blueness@gentoo.org> udns-0.1.ebuild:
Keyword ~ppc64
diff --git a/net-libs/udns/udns-0.2.ebuild b/net-libs/udns/udns-0.2.ebuild
new file mode 100644
index 000000000000..6abefae71acf
--- /dev/null
+++ b/net-libs/udns/udns-0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.2.ebuild,v 1.1 2012/09/05 15:51:52 jer Exp $
+
+EAPI="4"
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Async-capable DNS stub resolver library"
+HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
+SRC_URI="http://www.corpit.ru/mjt/udns/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 static"
+
+# Yes, this doesn't depend on any other library beside "system" set
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.1-respect-LDFLAGS.patch"
+}
+
+src_configure() {
+ # Uses non-standard configure script, econf doesn't work
+ CC=$(tc-getCC) ./configure $(use_enable ipv6) || die "Configure failed"
+}
+
+src_compile() {
+ emake sharedlib
+}
+
+src_install() {
+ dolib.so libudns.so.0 || die "dolib.so failed"
+ dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so" || die "dosym failed"
+
+ insinto /usr/include
+ doins udns.h
+
+ doman udns.3
+ dodoc NEWS NOTES TODO
+}