summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-11 00:04:12 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-11 00:04:12 +0000
commit9d2e54a4fe9967b4597b3bfb2f811eeec88dc312 (patch)
tree9cafcc112dc6ca139821e5329071e844833cce35 /net-libs/webkit-gtk
parentVersion bump. Update to EAPI 4, add doc USE flag, and add test phase. (diff)
downloadgentoo-2-9d2e54a4fe9967b4597b3bfb2f811eeec88dc312.tar.gz
gentoo-2-9d2e54a4fe9967b4597b3bfb2f811eeec88dc312.tar.bz2
gentoo-2-9d2e54a4fe9967b4597b3bfb2f811eeec88dc312.zip
Add 1.4.1, gtk2 (-r2xx) and gtk3 (-r3xx) versions, drop keywords, bug 365331
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog9
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.4.1-r200.ebuild130
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.4.1-r300.ebuild132
3 files changed, 270 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index e064e51022bc..890122f2cec6 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.108 2011/04/05 17:00:11 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.109 2011/06/11 00:04:12 nirbheek Exp $
+
+*webkit-gtk-1.4.1-r300 (11 Jun 2011)
+*webkit-gtk-1.4.1-r200 (11 Jun 2011)
+
+ 11 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +webkit-gtk-1.4.1-r200.ebuild, +webkit-gtk-1.4.1-r300.ebuild:
+ Add 1.4.1, gtk2 (-r2xx) and gtk3 (-r3xx) versions, drop keywords, bug 365331
05 Apr 2011; Christoph Mende <angelos@gentoo.org>
files/webkit-gtk-1.2.7-libpng15.patch:
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.4.1-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.4.1-r200.ebuild
new file mode 100644
index 000000000000..373ae6cbaf87
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-1.4.1-r200.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.4.1-r200.ebuild,v 1.1 2011/06/11 00:04:12 nirbheek Exp $
+
+EAPI="4"
+
+inherit autotools flag-o-matic eutils virtualx
+
+MY_P="webkit-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+# geoclue
+IUSE="aqua coverage debug doc spell +gstreamer +introspection +jit"
+
+# use sqlite, svg by default
+# dependency on >=x11-libs/gtk+-2.13:2 for gail
+RDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ virtual/jpeg
+ >=media-libs/libpng-1.4:0
+ x11-libs/cairo
+ >=dev-libs/glib-2.27.90:2
+ >=x11-libs/gtk+-2.13:2[aqua=]
+ >=dev-libs/icu-3.8.1-r1
+ >=net-libs/libsoup-2.33.6:2.4
+ dev-db/sqlite:3
+ >=x11-libs/pango-1.12
+
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10 )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+
+ spell? ( >=app-text/enchant-0.22 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.33
+ sys-devel/gettext
+ dev-util/gperf
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( x11-themes/hicolor-icon-theme )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ DOCS="Source/WebKit/gtk/NEWS Source/WebKit/gtk/ChangeLog"
+
+ # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
+ # https://bugs.webkit.org/show_bug.cgi?id=19775
+ use sparc && epatch "${FILESDIR}"/${PN}-1.1.15.2-unaligned.patch
+
+ # intermediate MacPorts hack while upstream bug is not fixed properly
+ # https://bugs.webkit.org/show_bug.cgi?id=28727
+ use aqua && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+
+ # Fix build on Darwin8 (10.4 Tiger)
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
+
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac
+
+ # Don't build tests if not needed, part of bug #343249
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+
+ # Prevent maintainer mode from being triggered during make
+ AT_M4DIR=Source/autotools eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this in LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co.
+ use sparc && filter-flags "-mcpu=*" "-mvis" "-mtune=*"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ local myconf
+
+ # XXX: Check Web Audio support
+ # XXX: webgl fails compilation
+ # XXX: WebKit2 is the new out-of-process model, doesn't work yet
+ myconf="
+ $(use_enable coverage)
+ $(use_enable debug)
+ $(use_enable spell spellcheck)
+ $(use_enable introspection)
+ $(use_enable gstreamer video)
+ $(use_enable jit)
+ --disable-webgl
+ --with-gtk=2.0
+ --disable-webkit2
+ --disable-web-sockets
+ $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
+ # Disable web-sockets per bug #326547
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ emake XDG_DATA_HOME="${T}/.local"
+}
+
+src_test() {
+ unset DISPLAY
+ # Tests need virtualx, bug #294691, bug #310695
+ # Set XDG_DATA_HOME for introspection tools, bug #323669
+ Xemake check XDG_DATA_HOME="${T}/.local"
+}
+
+src_install() {
+ default
+
+ # Remove .la files
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.4.1-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.4.1-r300.ebuild
new file mode 100644
index 000000000000..6651acd2ae37
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-1.4.1-r300.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.4.1-r300.ebuild,v 1.1 2011/06/11 00:04:12 nirbheek Exp $
+
+EAPI="4"
+
+inherit autotools flag-o-matic eutils virtualx
+
+MY_P="webkit-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+# geoclue
+IUSE="aqua coverage debug doc +gstreamer +introspection +jit spell"
+
+# use sqlite, svg by default
+# dependency on >=x11-libs/gtk+-2.13:2 for gail
+# Aqua support in gtk3 is untested
+RDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ virtual/jpeg
+ >=media-libs/libpng-1.4:0
+ x11-libs/cairo
+ >=dev-libs/glib-2.27.90:2
+ >=x11-libs/gtk+-3.0:3[aqua=]
+ >=dev-libs/icu-3.8.1-r1
+ >=net-libs/libsoup-2.33.6:2.4
+ dev-db/sqlite:3
+ >=x11-libs/pango-1.12
+
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10 )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+
+ spell? ( >=app-text/enchant-0.22 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.33
+ sys-devel/gettext
+ dev-util/gperf
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( x11-themes/hicolor-icon-theme )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ DOCS="Source/WebKit/gtk/NEWS Source/WebKit/gtk/ChangeLog"
+
+ # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
+ # https://bugs.webkit.org/show_bug.cgi?id=19775
+ use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+
+ # intermediate MacPorts hack while upstream bug is not fixed properly
+ # https://bugs.webkit.org/show_bug.cgi?id=28727
+ use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
+
+ # Fix build on Darwin8 (10.4 Tiger)
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
+
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac
+
+ # Don't build tests if not needed, part of bug #343249
+ # XXX: Fails to apply
+ #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+
+ # Prevent maintainer mode from being triggered during make
+ AT_M4DIR=Source/autotools eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this in LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co.
+ use sparc && filter-flags "-mcpu=*" "-mvis" "-mtune=*"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ local myconf
+
+ # XXX: Check Web Audio support
+ # XXX: webgl fails compilation
+ # XXX: WebKit2 is the new out-of-process model, doesn't work yet
+ myconf="
+ $(use_enable coverage)
+ $(use_enable debug)
+ $(use_enable spell spellcheck)
+ $(use_enable introspection)
+ $(use_enable gstreamer video)
+ $(use_enable jit)
+ --disable-webgl
+ --with-gtk=3.0
+ --disable-webkit2
+ --disable-web-sockets
+ $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
+ # Aqua support in gtk3 is untested
+ # Disable web-sockets per bug #326547
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ emake XDG_DATA_HOME="${T}/.local"
+}
+
+src_test() {
+ unset DISPLAY
+ # Tests need virtualx, bug #294691, bug #310695
+ # Set XDG_DATA_HOME for introspection tools, bug #323669
+ Xemake check XDG_DATA_HOME="${T}/.local"
+}
+
+src_install() {
+ default
+
+ # Remove .la files
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}