summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-05-23 17:25:12 +0000
committerAlin Năstac <mrness@gentoo.org>2007-05-23 17:25:12 +0000
commit79ff7feea1e9b41da05997f20fb147f87af12475 (patch)
treeff1e7129e7059d3b553398014bfc3ea6f9ed6ad6 /net-libs/wvstreams
parentAdd ~x86-fbsd keyword. Bug #176906. (diff)
downloadgentoo-2-79ff7feea1e9b41da05997f20fb147f87af12475.tar.gz
gentoo-2-79ff7feea1e9b41da05997f20fb147f87af12475.tar.bz2
gentoo-2-79ff7feea1e9b41da05997f20fb147f87af12475.zip
Avoid usage of obsolete member of the struct sigaction (#179401).
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog8
-rw-r--r--net-libs/wvstreams/files/digest-wvstreams-4.3-r23
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.3-sigaction.patch11
-rw-r--r--net-libs/wvstreams/wvstreams-4.3-r2.ebuild93
4 files changed, 114 insertions, 1 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 66e26e35ddb3..755b1a7f7335 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.102 2007/05/22 14:08:49 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.103 2007/05/23 17:25:12 mrness Exp $
+
+*wvstreams-4.3-r2 (23 May 2007)
+
+ 23 May 2007; Alin Năstac <mrness@gentoo.org>
+ +files/wvstreams-4.3-sigaction.patch, +wvstreams-4.3-r2.ebuild:
+ Avoid usage of obsolete member of the struct sigaction (#179401).
22 May 2007; Gustavo Zacarias <gustavoz@gentoo.org>
wvstreams-4.3-r1.ebuild:
diff --git a/net-libs/wvstreams/files/digest-wvstreams-4.3-r2 b/net-libs/wvstreams/files/digest-wvstreams-4.3-r2
new file mode 100644
index 000000000000..3b2f6d51a4f1
--- /dev/null
+++ b/net-libs/wvstreams/files/digest-wvstreams-4.3-r2
@@ -0,0 +1,3 @@
+MD5 eb34544384c951fd14470d583273e02a wvstreams-4.3.tar.gz 1294177
+RMD160 fb6c480903cb725bf4911a05bfa1ef12bf05dfec wvstreams-4.3.tar.gz 1294177
+SHA256 54b2a693ef67fde375292d768fc6471bb00105870714cc4051289986a51aabb9 wvstreams-4.3.tar.gz 1294177
diff --git a/net-libs/wvstreams/files/wvstreams-4.3-sigaction.patch b/net-libs/wvstreams/files/wvstreams-4.3-sigaction.patch
new file mode 100644
index 000000000000..a5da5fcdf83f
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.3-sigaction.patch
@@ -0,0 +1,11 @@
+diff -Nru wvstreams-4.3.orig/utils/wvcrash.cc wvstreams-4.3/utils/wvcrash.cc
+--- wvstreams-4.3.orig/utils/wvcrash.cc 2007-05-23 08:05:35.000000000 +0300
++++ wvstreams-4.3/utils/wvcrash.cc 2007-05-23 20:14:37.000000000 +0300
+@@ -349,7 +349,6 @@
+ act.sa_handler = wvcrash;
+ sigfillset(&act.sa_mask);
+ act.sa_flags = SA_ONSTACK | SA_RESTART;
+- act.sa_restorer = NULL;
+
+ if (sigaction(sig, &act, NULL))
+ fprintf(stderr, "Failed to setup wvcrash handler for signal %d: %s\n",
diff --git a/net-libs/wvstreams/wvstreams-4.3-r2.ebuild b/net-libs/wvstreams/wvstreams-4.3-r2.ebuild
new file mode 100644
index 000000000000..606bb82697cc
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.3-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.3-r2.ebuild,v 1.1 2007/05/23 17:25:12 mrness Exp $
+
+WANT_AUTOCONF=2.59
+WANT_AUTOMAKE=none
+
+inherit eutils fixheadtails autotools qt3
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://alumnit.ca/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="qt3 qdbm pam slp doc debug"
+
+RESTRICT="test"
+
+RDEPEND=">=sys-libs/db-3
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/xplc-0.3.13
+ qt3? ( $(qt_min_version 3.1) )
+ qdbm? ( dev-db/qdbm )
+ pam? ( >=sys-libs/pam-0.75 )
+ slp? ( >=net-libs/openslp-1.0.9a )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-linux-serial.patch"
+ epatch "${FILESDIR}/${P}-wireless-user.patch"
+ epatch "${FILESDIR}/${P}-uniconfd-ini.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ epatch "${FILESDIR}/${P}-sane-cflags.patch"
+ epatch "${FILESDIR}/${P}-64bit.patch"
+ epatch "${FILESDIR}/${P}-type-punned.patch"
+ epatch "${FILESDIR}/${P}-sigaction.patch"
+
+ epatch "${FILESDIR}/${P}-external-xplc.patch"
+ local XPLC_VER=`best_version dev-libs/xplc`
+ XPLC_VER=${XPLC_VER#*/*-} #reduce it to ${PV}-${PR}
+ XPLC_VER=${XPLC_VER%%[_-]*} # main version without beta/pre/patch/revision
+ sed -i -e "s:^xplc_version=.*:xplc_version='${XPLC_VER}':" "${S}/configure.ac" \
+ || die "failed to set current xplc version"
+ rm -r "${S}/xplc"
+
+ use qt3 && epatch "${FILESDIR}/${P}-MOC-fix.patch"
+
+ ht_fix_file "${S}/configure.ac"
+
+ #needed by xplc and as-needed patch:
+ cd "${S}"
+ eautoconf || die "autoconf failed"
+ #without following, the makefile would remove some files and request
+ #you to run ./configure again
+ touch include/wvautoconf.h.in configure
+}
+
+src_compile() {
+ econf \
+ `use_with qdbm` \
+ `use_with pam` \
+ `use_with slp openslp` \
+ `use_with qt3 qt` \
+ `use_enable debug` \
+ --without-tcl \
+ --without-swig \
+ --with-xplc \
+ --enable-verbose \
+ --with-bdb \
+ --with-zlib \
+ --with-openssl \
+ || die "configure failed"
+ emake CXXOPTS="-fPIC -DPIC" COPTS="-fPIC -DPIC" || die "compile failed"
+ use doc && doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use doc ; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}