summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-06-04 12:54:18 +0000
committerDror Levin <spatz@gentoo.org>2010-06-04 12:54:18 +0000
commitd1ed3b708cf322d6c88b4948cf3f4002863ddc10 (patch)
tree4019948f0b6b406f5eb621c0b08a5866e68da88d /net-libs/wvstreams
parentold (diff)
downloadgentoo-2-d1ed3b708cf322d6c88b4948cf3f4002863ddc10.tar.gz
gentoo-2-d1ed3b708cf322d6c88b4948cf3f4002863ddc10.tar.bz2
gentoo-2-d1ed3b708cf322d6c88b4948cf3f4002863ddc10.zip
Add patch for compatibility with openssl-1.0.0, bug 304283. Thanks to Hanno Boeck.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog9
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch14
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild90
3 files changed, 112 insertions, 1 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index c557eefe5761..c773470b79fc 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/wvstreams
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.132 2010/05/31 19:34:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.133 2010/06/04 12:54:18 spatz Exp $
+
+*wvstreams-4.6.1-r1 (04 Jun 2010)
+
+ 04 Jun 2010; Dror Levin <spatz@gentoo.org> +wvstreams-4.6.1-r1.ebuild,
+ +files/wvstreams-4.6.1-openssl-1.0.0.patch:
+ Add patch for compatibility with openssl-1.0.0, bug 304283. Thanks to
+ Hanno Boeck.
31 May 2010; Markus Meier <maekke@gentoo.org> wvstreams-4.6.1.ebuild:
x86 stable, bug #321637
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
new file mode 100644
index 000000000000..6c32f0678ad8
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
@@ -0,0 +1,14 @@
+--- wvstreams-4.6.1/crypto/wvx509.cc 2008-10-23 22:23:49.000000000 +0200
++++ wvstreams-4.6.1-1/crypto/wvx509.cc 2010-01-27 11:09:06.000000000 +0100
+@@ -1157,7 +1157,11 @@
+
+ if (ext)
+ {
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
++#else
+ X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
++#endif
+ if (!method)
+ {
+ WvDynBuf buf;
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..4f4d21489663
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild,v 1.1 2010/06/04 12:54:18 spatz Exp $
+
+EAPI=2
+inherit autotools toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="sys-libs/readline
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.2.14 )
+ dev-libs/openssl
+ pam? ( sys-libs/pam )
+ virtual/c++-tr1-functional"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ if has_version '>=sys-devel/gcc-4.1' && ! has_version '>=dev-libs/boost-1.34.1'
+ then
+ if ! version_is_at_least 4.1 "$(gcc-fullversion)"
+ then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or >=dev-libs/boost-1.34.1 must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-make.patch \
+ "${FILESDIR}"/${P}-openssl-1.0.0.patch
+ eautoreconf
+ cd argp
+ eautoreconf
+}
+
+src_configure() {
+ export CXX="$(tc-getCXX)"
+
+ econf \
+ $(use_enable debug) \
+ --disable-optimization \
+ $(use_with dbus) \
+ --with-openssl \
+ $(use_with pam) \
+ --without-tcl \
+ --without-qt \
+ --with-zlib \
+ --without-valgrind
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README*
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}