summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-10-20 19:01:49 +0000
committerLars Weiler <pylon@gentoo.org>2007-10-20 19:01:49 +0000
commit54e728be177a37837c9400801f74292f754bc954 (patch)
tree6229cae149a3cbbd50545573f05c24c47f67ec99 /net-libs/xyssl
parentinsinto is -safe. (diff)
downloadgentoo-2-54e728be177a37837c9400801f74292f754bc954.tar.gz
gentoo-2-54e728be177a37837c9400801f74292f754bc954.tar.bz2
gentoo-2-54e728be177a37837c9400801f74292f754bc954.zip
Version bump; thanks to Mikael Voss <ffefd6@haemoglobin.org> for the reminder.
(Portage version: 2.1.3.14)
Diffstat (limited to 'net-libs/xyssl')
-rw-r--r--net-libs/xyssl/ChangeLog7
-rw-r--r--net-libs/xyssl/files/digest-xyssl-0.83
-rw-r--r--net-libs/xyssl/xyssl-0.8.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/xyssl/ChangeLog b/net-libs/xyssl/ChangeLog
index 88eda8aaafe0..d236adc45833 100644
--- a/net-libs/xyssl/ChangeLog
+++ b/net-libs/xyssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/xyssl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xyssl/ChangeLog,v 1.1 2007/07/13 18:31:09 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xyssl/ChangeLog,v 1.2 2007/10/20 19:01:49 pylon Exp $
+
+*xyssl-0.8 (20 Oct 2007)
+
+ 20 Oct 2007; Lars Weiler <pylon@gentoo.org> +xyssl-0.8.ebuild:
+ Version bump; thanks to Mikael Voss <ffefd6@haemoglobin.org> for the reminder.
*xyssl-0.7 (13 Jul 2007)
diff --git a/net-libs/xyssl/files/digest-xyssl-0.8 b/net-libs/xyssl/files/digest-xyssl-0.8
new file mode 100644
index 000000000000..723509a4231e
--- /dev/null
+++ b/net-libs/xyssl/files/digest-xyssl-0.8
@@ -0,0 +1,3 @@
+MD5 5c80e021e3bca4b77fbe2429c9e61541 xyssl-0.8.tgz 190953
+RMD160 b4f26636b8f7eba8dbef84fa7a99d0885ac2aebc xyssl-0.8.tgz 190953
+SHA256 203435dbc70e6431202583dd44e96beac8e7dfa2a79b1825c84b8e8842255664 xyssl-0.8.tgz 190953
diff --git a/net-libs/xyssl/xyssl-0.8.ebuild b/net-libs/xyssl/xyssl-0.8.ebuild
new file mode 100644
index 000000000000..27e2eb75b263
--- /dev/null
+++ b/net-libs/xyssl/xyssl-0.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xyssl/xyssl-0.8.ebuild,v 1.1 2007/10/20 19:01:49 pylon Exp $
+
+DESCRIPTION="Cryptographic library for embedded systems"
+HOMEPAGE="http://xyssl.org/"
+SRC_URI="http://xyssl.org/code/download/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~sparc ~x86"
+IUSE="examples sse2"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ cd "${S}/library"
+ if use sse2 ; then
+ sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
+ else
+ sed -i '15iCFLAGS += -fPIC' Makefile
+ fi
+ emake libxyssl.a || die "emake failed"
+ emake libxyssl.so || die "emake failed"
+
+ if use examples ; then
+ cd "${S}"/programs
+ emake all
+ fi
+}
+
+src_test() {
+ cd "${S}"/programs
+ emake test/selftest
+ ./test/selftest || die "selftest failed"
+}
+
+src_install() {
+ dodir /usr/include/xyssl
+ insinto /usr/include/xyssl
+ doins include/xyssl/*.h
+ dolib.so library/libxyssl.so
+ dolib.a library/libxyssl.a
+
+ if use examples ; then
+ for p in programs/*/* ; do
+ if [ -x "${p}" ] ; then
+ f=xyssl_`basename "${p}"`
+ newbin "${p}" "${f}"
+ fi
+ done
+ for e in aes hash pkey ssl test ; do
+ docinto "${e}"
+ dodoc programs/"${e}"/*.c
+ dodoc programs/"${e}"/*.txt
+ done
+ fi
+}