summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-23 19:35:01 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-23 19:35:01 +0000
commit0e847114288775756306ce1d51ec64b498640d54 (patch)
tree1e848ac998bc5e56c571c6152f961a24481b05f6 /net-libs
parentVersion bump (diff)
downloadgentoo-2-0e847114288775756306ce1d51ec64b498640d54.tar.gz
gentoo-2-0e847114288775756306ce1d51ec64b498640d54.tar.bz2
gentoo-2-0e847114288775756306ce1d51ec64b498640d54.zip
Do not compile test program and move to EAPI-2
(Portage version: 13845-svn/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libunicall/ChangeLog6
-rw-r--r--net-libs/libunicall/libunicall-0.0.6_pre1.ebuild16
2 files changed, 14 insertions, 8 deletions
diff --git a/net-libs/libunicall/ChangeLog b/net-libs/libunicall/ChangeLog
index 9f61e28cf5d0..12e802ba5b57 100644
--- a/net-libs/libunicall/ChangeLog
+++ b/net-libs/libunicall/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libunicall
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libunicall/ChangeLog,v 1.5 2009/07/23 15:44:12 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libunicall/ChangeLog,v 1.6 2009/07/23 19:35:01 volkmar Exp $
+
+ 23 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
+ libunicall-0.0.6_pre1.ebuild:
+ Do not compile test program and move to EAPI-2
23 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
libunicall-0.0.6_pre1.ebuild:
diff --git a/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild b/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild
index 5d502eedd806..8003e5412970 100644
--- a/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild
+++ b/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild,v 1.3 2009/07/23 15:44:12 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libunicall/libunicall-0.0.6_pre1.ebuild,v 1.4 2009/07/23 19:35:01 volkmar Exp $
+
+EAPI="2"
inherit eutils autotools
@@ -20,21 +22,21 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-${PV/_pre*}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ # do not compile test program
+ sed -i -e "/testcall/d" Makefile.am || die "sed failed"
+
epatch "${FILESDIR}/${P}-expose-internal-headers.patch"
epatch "${FILESDIR}/${P}--as-needed.2.patch"
eautoreconf
}
src_compile() {
- econf || die "econf failed"
# bug #277783
emake -j1 || die "emake failed"
}
src_install () {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc AUTHORS INSTALL NEWS README || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README || die "dodoc failed"
}