summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-17 13:52:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-17 13:52:22 +0000
commit185b2240f8240cf0775a9896ca9cdd241c584c63 (patch)
treeaac1d3f85b1ed63dc660392a22bf610baf17309d /net-libs
parentFix for tilde package.unmask and package.keyword clean (diff)
downloadgentoo-2-185b2240f8240cf0775a9896ca9cdd241c584c63.tar.gz
gentoo-2-185b2240f8240cf0775a9896ca9cdd241c584c63.tar.bz2
gentoo-2-185b2240f8240cf0775a9896ca9cdd241c584c63.zip
Bump to 2.7.13. Thanks to Alessio Cassibba. Renames patch.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/ChangeLog8
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch98
-rw-r--r--net-libs/gsoap/gsoap-2.7.13.ebuild59
3 files changed, 164 insertions, 1 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index e5506ae38793..18cb188821e9 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.3 2009/03/05 20:30:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.4 2009/08/17 13:52:22 patrick Exp $
+
+*gsoap-2.7.13 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org> +gsoap-2.7.13.ebuild,
+ +files/gsoap-2.7-fix-pre-iso-headers.patch:
+ Bump to 2.7.13. Thanks to Alessio Cassibba. Renames patch.
*gsoap-2.7.12-r1 (05 Mar 2009)
diff --git a/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
new file mode 100644
index 000000000000..5762d5282211
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
@@ -0,0 +1,98 @@
+--- gsoap/samples/factorytest/factorytest.cpp.orig 2009-03-04 01:16:22.300484305 +0100
++++ gsoap/samples/factorytest/factorytest.cpp 2009-03-04 01:15:47.656485143 +0100
+@@ -49,7 +49,7 @@
+ #include "soapH.h"
+ #include "factorytest.nsmap"
+
+-#include <iostream.h>
++#include <iostream>
+
+ // default factory service endpoint:
+ const char *factory = "http://localhost:18085";
+@@ -167,7 +167,7 @@
+ int main(int argc, char **argv)
+ { if (argc > 1)
+ factory = argv[1]; // use factory from command line arg by default
+- cout << "Connecting to factory " << factory << endl;
++ std::cout << "Connecting to factory " << factory << std::endl;
+ Adder adder; // create unique new remote adder object
+ Counter counter1("myCounter"); // new counter object "myCounter" (created if not exists)
+ Counter counter2("myCounter"); // lookup and use counter "myCounter" (this is an alias to counter1!)
+@@ -175,22 +175,22 @@
+ counter1.set(adder.get());
+ adder.add(3.0);
+ counter1.inc();
+- cout << "Adder=" << adder.get() << endl;
+- cout << "Counter=" << counter2.get() << endl; // counter2 is an alias for counter1 so this prints the value of counter1
+- cout << "Sleep for 90 seconds to test factory server purging objects:" << endl;
++ std::cout << "Adder=" << adder.get() << std::endl;
++ std::cout << "Counter=" << counter2.get() << std::endl; // counter2 is an alias for counter1 so this prints the value of counter1
++ std::cout << "Sleep for 90 seconds to test factory server purging objects:" << std::endl;
+ // counter is periodically incremented which keeps it alive
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ // after 90 secs, the adder should be gone
+- cout << "Adder is no longer available:" << endl;
++ std::cout << "Adder is no longer available:" << std::endl;
+ adder.add(3.0);
+- cout << "Adder status = " << adder.status << endl;
++ std::cout << "Adder status = " << adder.status << std::endl;
+ return 0;
+ }
+--- gsoap/samples/lu/luclient.cpp.orig 2009-03-04 01:16:48.632483467 +0100
++++ gsoap/samples/lu/luclient.cpp 2009-03-04 01:17:54.550483188 +0100
+@@ -32,7 +32,7 @@
+ */
+
+ #include "soapH.h"
+-#include <iostream.h>
++#include <iostream>
+
+ const char luserver[] = "http://websrv.cs.fsu.edu/~engelen/luserver.cgi";
+
+@@ -51,14 +51,14 @@
+ a[3].resize(2,3); // 2-element vector indexed from 2 to 3
+ a[3][2] = 1;
+ a[3][3] = 2;
+- cout << "* Demonstration example *" << endl;
+- cout << "Matrix:" << endl;
++ std::cout << "* Demonstration example *" << std::endl;
++ std::cout << "Matrix:" << std::endl;
+ a.print();
+ vector b(soap, 3);
+ b[1] = 1;
+ b[2] = 2;
+ b[3] = 3;
+- cout << "Vector:" << endl;
++ std::cout << "Vector:" << std::endl;
+ b.print();
+ vector x(soap);
+ if (argc < 2)
+@@ -71,7 +71,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Solution vector from service:" << endl;
++ { std::cout << "Solution vector from service:" << std::endl;
+ x.print();
+ }
+ matrix a1(soap);
+@@ -80,7 +80,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Inverse matrix matrix from service:" << endl;
++ { std::cout << "Inverse matrix matrix from service:" << std::endl;
+ a1.print();
+ }
+ soap_destroy(soap);
diff --git a/net-libs/gsoap/gsoap-2.7.13.ebuild b/net-libs/gsoap/gsoap-2.7.13.ebuild
new file mode 100644
index 000000000000..821a71255b20
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.13.ebuild,v 1.1 2009/08/17 13:52:22 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="${PN}-2.7"
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples +ssl"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
+}
+
+src_configure() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable examples samples) \
+ $(use_enable debug) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodir /usr/share/doc/${P}
+ dodoc LICENSE.txt NOTES.txt README.txt
+ dohtml changelog.html
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ rm -rf gsoap/samples/Makefile* README.txt
+ doins -r gsoap/samples
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/
+ fi
+}