summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-09-07 16:50:35 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-09-07 16:50:35 +0000
commit353db4bf342fa8e92993dd36543e7ed08d9bb6ed (patch)
treef99ce7ad4c50662b09b1fe9d40e12110a6d7546a /net-libs
parentVersion bump. (diff)
downloadgentoo-2-353db4bf342fa8e92993dd36543e7ed08d9bb6ed.tar.gz
gentoo-2-353db4bf342fa8e92993dd36543e7ed08d9bb6ed.tar.bz2
gentoo-2-353db4bf342fa8e92993dd36543e7ed08d9bb6ed.zip
Version bump, #236178
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/ChangeLog8
-rw-r--r--net-libs/libetpan/libetpan-0.56.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 179500ee643a..57327e91be5b 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.69 2008/05/30 07:13:13 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.70 2008/09/07 16:50:35 dertobi123 Exp $
+
+*libetpan-0.56 (07 Sep 2008)
+
+ 07 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +libetpan-0.56.ebuild:
+ Version bump, #236178
30 May 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Andrej Kacian (Ticho) from metadata.xml (as per #59986).
diff --git a/net-libs/libetpan/libetpan-0.56.ebuild b/net-libs/libetpan/libetpan-0.56.ebuild
new file mode 100644
index 000000000000..e20998e429b6
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.56.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.56.ebuild,v 1.1 2008/09/07 16:50:35 dertobi123 Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ liblockfile? ( net-libs/liblockfile )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable berkdb db) \
+ $(use_with sasl) \
+ $(use_enable ipv6) \
+ $(use_enable liblockfile lockfile) \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-0.53."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}