summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-09-30 22:48:41 +0000
committerBen de Groot <yngwin@gentoo.org>2009-09-30 22:48:41 +0000
commit3a9193580ff695e53ebdc9f1d0b874a5bb6dfc87 (patch)
treef78acdecfe2885a324c037698f88a0fcca9314a7 /net-libs
parent3.4.0 version bump. This version brings new capabilities such as: support for... (diff)
downloadgentoo-2-3a9193580ff695e53ebdc9f1d0b874a5bb6dfc87.tar.gz
gentoo-2-3a9193580ff695e53ebdc9f1d0b874a5bb6dfc87.tar.bz2
gentoo-2-3a9193580ff695e53ebdc9f1d0b874a5bb6dfc87.zip
Version bump
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 458efc59abc2..1fdb083d2fc8 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.64 2009/08/15 23:29:06 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.65 2009/09/30 22:48:41 yngwin Exp $
+
+*rb_libtorrent-0.14.6 (30 Sep 2009)
+
+ 30 Sep 2009; Ben de Groot <yngwin@gentoo.org>
+ +rb_libtorrent-0.14.6.ebuild:
+ Version bump
*rb_libtorrent-0.14.5 (15 Aug 2009)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
new file mode 100644
index 000000000000..c585c12e56f8
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild,v 1.1 2009/09/30 22:48:41 yngwin Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug doc examples python test"
+
+DEPEND="!net-libs/libtorrent
+ || ( >=dev-libs/boost-1.35
+ ( ~dev-libs/boost-1.34.1 dev-cpp/asio ) )
+ python? ( || ( >=dev-libs/boost-1.35.0-r5[python]
+ =dev-libs/boost-1.35.0-r2 ) )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ append-ldflags -pthread
+
+ #use multi-threading versions of boost libs
+ local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ --with-boost-asio=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-python=boost_python-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ local LOGGING
+ use debug && LOGGING="--with-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ --with-zlib=system \
+ --with-asio=system \
+ ${LOGGING} \
+ ${BOOST_LIBS}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
+ if use doc ; then
+ dohtml docs/* || die "Could not install HTML documentation"
+ fi
+}