summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-23 03:37:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-23 03:37:29 +0000
commit6cdea938c1f3182077260078fb5a94b5ef65b157 (patch)
tree8b290cce4d73da534ad087362a429ce57d9214b5 /net-libs
parentman page is now readable (diff)
downloadgentoo-2-6cdea938c1f3182077260078fb5a94b5ef65b157.tar.gz
gentoo-2-6cdea938c1f3182077260078fb5a94b5ef65b157.tar.bz2
gentoo-2-6cdea938c1f3182077260078fb5a94b5ef65b157.zip
cleaned up ebuild
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/linc/linc-0.5.2.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/net-libs/linc/linc-0.5.2.ebuild b/net-libs/linc/linc-0.5.2.ebuild
index 3ab4f92b6d52..109d50fa8368 100644
--- a/net-libs/linc/linc-0.5.2.ebuild
+++ b/net-libs/linc/linc-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.2.ebuild,v 1.2 2002/08/16 02:57:06 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.2.ebuild,v 1.3 2002/08/23 03:37:29 seemant Exp $
inherit libtool
@@ -24,25 +24,19 @@ DEPEND="${RDEPEND}
src_compile() {
elibtoolize
local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
# if this is disabled (use) ORBit2 will fail to build. Just force it on
- myconf="${myconf} --with-openssl"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die
+ myconf="${myconf} --with-openssl"
+
+ econf ${myconf} || die
emake || die
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
+ einstall || die
- dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* NEWS TODO
}