summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-09 15:57:43 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-09 15:57:43 +0000
commit80382766fdc52531a1ffb1adf04c76fc007117a8 (patch)
tree238f492b35833310b539848ee89cda6ed31d5316 /net-libs
parentFix Changelog (diff)
downloadgentoo-2-80382766fdc52531a1ffb1adf04c76fc007117a8.tar.gz
gentoo-2-80382766fdc52531a1ffb1adf04c76fc007117a8.tar.bz2
gentoo-2-80382766fdc52531a1ffb1adf04c76fc007117a8.zip
Version BUmp, move to EAPI=4
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog7
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index da449b09dc0b..ba9c33826573 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.169 2012/05/05 02:54:28 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.170 2012/06/09 15:57:43 jlec Exp $
+
+*libtorrent-0.13.2 (09 Jun 2012)
+
+ 09 Jun 2012; Justin Lecher <jlec@gentoo.org> +libtorrent-0.13.2.ebuild:
+ Version BUmp, move to EAPI=4
05 May 2012; Jeff Horelick <jdhore@gentoo.org> libtorrent-0.12.5.ebuild,
libtorrent-0.12.6.ebuild, libtorrent-0.12.7.ebuild,
diff --git a/net-libs/libtorrent/libtorrent-0.13.2.ebuild b/net-libs/libtorrent/libtorrent-0.13.2.ebuild
new file mode 100644
index 000000000000..0bc71d98bc89
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.13.2.ebuild,v 1.1 2012/06/09 15:57:43 jlec Exp $
+
+EAPI=4
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+# epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}