summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-04 10:04:42 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-04 10:04:42 +0000
commit81897935e4d96d20030e8172134e01e86cd88b0f (patch)
treeecb77390ad31a8479e2daf0b0e67bde7a1dda575 /net-libs
parentStable for amd64, wrt bug #402095 (diff)
downloadgentoo-2-81897935e4d96d20030e8172134e01e86cd88b0f.tar.gz
gentoo-2-81897935e4d96d20030e8172134e01e86cd88b0f.tar.bz2
gentoo-2-81897935e4d96d20030e8172134e01e86cd88b0f.zip
Version bump, remove old.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog10
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild (renamed from net-libs/webkit-gtk/webkit-gtk-1.6.1-r200.ebuild)60
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild (renamed from net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild)48
3 files changed, 72 insertions, 46 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index fdfc777df2a5..c430487e2ee7 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.138 2012/01/18 21:06:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.139 2012/02/04 10:04:42 pacho Exp $
+
+*webkit-gtk-1.6.3-r200 (04 Feb 2012)
+*webkit-gtk-1.6.3-r300 (04 Feb 2012)
+
+ 04 Feb 2012; Pacho Ramos <pacho@gentoo.org> +webkit-gtk-1.6.3-r200.ebuild,
+ +webkit-gtk-1.6.3-r300.ebuild, -webkit-gtk-1.6.1-r200.ebuild,
+ -webkit-gtk-1.6.1-r300.ebuild:
+ Version bump, remove old.
18 Jan 2012; Markus Meier <maekke@gentoo.org> webkit-gtk-1.6.1-r301.ebuild:
arm stable, bug #393007
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild
index 46ec4732f9cb..ba7b54d5bc43 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r200.ebuild,v 1.1 2011/09/30 13:52:33 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild,v 1.1 2012/02/04 10:04:42 pacho Exp $
EAPI="4"
-inherit autotools eutils flag-o-matic eutils virtualx
+inherit autotools eutils flag-o-matic eutils virtualx gnome2-utils toolchain-funcs
MY_P="webkit-${PV}"
DESCRIPTION="Open source web browser engine"
HOMEPAGE="http://www.webkitgtk.org/"
-# Upstream is still shipping silly gzip files
-#SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.xz"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.xz"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
-~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue
+
IUSE="aqua coverage debug +gstreamer +introspection +jit spell webgl"
+
# bug 372493
REQUIRED_USE="introspection? ( gstreamer )"
@@ -63,28 +62,44 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
DOCS="ChangeLog NEWS" # other ChangeLog files handled by src_install
+ # Fix arches that use 64-bit double type
+ # https://bugs.webkit.org/show_bug.cgi?id=69940
+ epatch "${FILESDIR}/${PN}-1.6.1-double-conversion.patch"
+
# FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
# https://bugs.webkit.org/show_bug.cgi?id=19775
- use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+ # TODO: FAILS TO APPLY!
+ #use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
# intermediate MacPorts hack while upstream bug is not fixed properly
# https://bugs.webkit.org/show_bug.cgi?id=28727
- use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
+ use aqua && epatch "${FILESDIR}"/${PN}-1.6.1-darwin-quartz.patch
- # Fix build on Darwin8 (10.4 Tiger)
- # XXX: Fails to apply
- #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
+ # Skip tests phase: here we will place tests we need to skip, any
+ # skipped test needs to have an upstream report and needs to be
+ # rechecked on every major bump.
+ #
+ # adjustments test is flacky, https://bugs.webkit.org/show_bug.cgi?id=68647
+ sed -i -e '/\/webkit\/webview\/adjustments/d' Source/WebKit/gtk/tests/testwebview.c || die
+ # the same for icon-uri one, https://bugs.webkit.org/show_bug.cgi?id=69228
+ sed -i -e '/\/webkit\/webview\/icon-uri/d' Source/WebKit/gtk/tests/testwebview.c || die
- # Don't force -O2
- sed -i 's/-O2//g' "${S}"/configure.ac
+ # Drop DEPRECATED flags
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' GNUmakefile.am || die
- # Don't build tests if not needed, part of bug #343249
- # XXX: Fails to apply
- #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac || die
# Required for webgl; https://bugs.webkit.org/show_bug.cgi?id=69085
mkdir -p DerivedSources/ANGLE
+ # We need to reset some variables to prevent permissions problems and failures
+ # like https://bugs.webkit.org/show_bug.cgi?id=35471 and bug #323669
+ gnome2_environment_reset
+
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
# Prevent maintainer mode from being triggered during make
AT_M4DIR=Source/autotools eautoreconf
}
@@ -122,18 +137,11 @@ src_configure() {
econf ${myconf}
}
-src_compile() {
- # Fix sandbox error with USE="introspection"
- # https://bugs.webkit.org/show_bug.cgi?id=35471
- emake XDG_DATA_HOME="${T}/.local"
-}
-
src_test() {
unset DISPLAY
# Tests need virtualx, bug #294691, bug #310695
- # Set XDG_DATA_HOME for introspection tools, bug #323669
# Parallel tests sometimes fail
- Xemake -j1 check XDG_DATA_HOME="${T}/.local"
+ Xemake -j1 check
}
src_install() {
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild
index f035fa593137..bbba7ad67836 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild,v 1.2 2011/11/29 19:01:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild,v 1.1 2012/02/04 10:04:42 pacho Exp $
EAPI="4"
-inherit autotools eutils flag-o-matic eutils virtualx
+inherit autotools eutils flag-o-matic eutils virtualx gnome2-utils
MY_P="webkit-${PV}"
DESCRIPTION="Open source web browser engine"
HOMEPAGE="http://www.webkitgtk.org/"
-# Upstream is still shipping silly gzip files
-#SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.xz"
+SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.xz"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
-~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue
IUSE="aqua coverage debug doc +gstreamer +introspection +jit spell webgl"
+
# bug 372493
REQUIRED_USE="introspection? ( gstreamer )"
@@ -66,20 +64,35 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
DOCS="ChangeLog NEWS" # other ChangeLog files handled by src_install
+ # Fix arches that use 64-bit double type
+ # https://bugs.webkit.org/show_bug.cgi?id=69940
+ epatch "${FILESDIR}/${PN}-1.6.1-double-conversion.patch"
+
# FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
# https://bugs.webkit.org/show_bug.cgi?id=19775
- use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
+ # TODO: FAILS TO APPLY!
+ #use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
- # Don't force -O2
- sed -i 's/-O2//g' "${S}"/configure.ac
+ # intermediate MacPorts hack while upstream bug is not fixed properly
+ # https://bugs.webkit.org/show_bug.cgi?id=28727
+ use aqua && epatch "${FILESDIR}"/${PN}-1.6.1-darwin-quartz.patch
+
+ # Drop DEPRECATED flags
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' GNUmakefile.am || die
- # Don't build tests if not needed, part of bug #343249
- # XXX: Fails to apply
- #epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
+ # Don't force -O2
+ sed -i 's/-O2//g' "${S}"/configure.ac || die
# Required for webgl; https://bugs.webkit.org/show_bug.cgi?id=69085
mkdir -p DerivedSources/ANGLE
+ # We need to reset some variables to prevent permissions problems and failures
+ # like https://bugs.webkit.org/show_bug.cgi?id=35471 and bug #323669
+ gnome2_environment_reset
+
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
# Prevent maintainer mode from being triggered during make
AT_M4DIR=Source/autotools eautoreconf
}
@@ -119,9 +132,7 @@ src_configure() {
}
src_compile() {
- # Fix sandbox error with USE="introspection"
- # https://bugs.webkit.org/show_bug.cgi?id=35471
- emake XDG_DATA_HOME="${T}/.local"
+ default
# ${PN} neither ships, nor builds documentation on its own
if use doc; then
@@ -132,9 +143,8 @@ src_compile() {
src_test() {
unset DISPLAY
# Tests need virtualx, bug #294691, bug #310695
- # Set XDG_DATA_HOME for introspection tools, bug #323669
# Parallel tests sometimes fail
- Xemake -j1 check XDG_DATA_HOME="${T}/.local"
+ Xemake -j1 check
}
src_install() {