summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-09-17 13:08:50 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-09-17 13:08:50 +0000
commit85f940100876363a81dfb4452b54598461153e75 (patch)
tree4e07c182e5b27cd2eda588b96ef308437b01b130 /net-libs
parentUTF-8 fixes. (diff)
downloadgentoo-2-85f940100876363a81dfb4452b54598461153e75.tar.gz
gentoo-2-85f940100876363a81dfb4452b54598461153e75.tar.bz2
gentoo-2-85f940100876363a81dfb4452b54598461153e75.zip
Version bump. Added sasl and gnutls USE flags.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/ChangeLog7
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.391
-rw-r--r--net-libs/libetpan/libetpan-0.39.ebuild35
3 files changed, 42 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index f4d7f1d91a77..be2e1582f564 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.10 2005/08/23 15:19:47 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.11 2005/09/17 13:08:50 ticho Exp $
+
+*libetpan-0.39 (17 Sep 2005)
+
+ 17 Sep 2005; Andrej Kacian <ticho@gentoo.org> +libetpan-0.39.ebuild:
+ Version bump. Added sasl and gnutls USE flags.
23 Aug 2005; Andrej Kacian <ticho@gentoo.org> -libetpan-0.36.ebuild,
-libetpan-0.37.ebuild, libetpan-0.38.ebuild:
diff --git a/net-libs/libetpan/files/digest-libetpan-0.39 b/net-libs/libetpan/files/digest-libetpan-0.39
new file mode 100644
index 000000000000..0c30626252f0
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.39
@@ -0,0 +1 @@
+MD5 d4659640999458a816a4e48c15653420 libetpan-0.39.tar.gz 1115262
diff --git a/net-libs/libetpan/libetpan-0.39.ebuild b/net-libs/libetpan/libetpan-0.39.ebuild
new file mode 100644
index 000000000000..bc0efad1217e
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.39.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.39.ebuild,v 1.1 2005/09/17 13:08:50 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="berkdb debug gnutls sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local myconf
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with gnutls` \
+ `use_with ssl openssl` \
+ `use_with sasl` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}