summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-06 08:00:09 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-06 08:00:09 +0000
commit921f7295dbb94e6ec1a19fee3464af044a2d3a71 (patch)
tree875fa7bb14cbcbdaea411cdfc36bfc82e4076d85 /net-libs
parentScript needs to be executable (diff)
downloadgentoo-2-921f7295dbb94e6ec1a19fee3464af044a2d3a71.tar.gz
gentoo-2-921f7295dbb94e6ec1a19fee3464af044a2d3a71.tar.bz2
gentoo-2-921f7295dbb94e6ec1a19fee3464af044a2d3a71.zip
Make pulseaudio optional (bug #399111).
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog6
-rw-r--r--net-libs/gtk-vnc/files/gtk-vnc-0.5.0-pulseaudio-automagic.patch55
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild19
3 files changed, 75 insertions, 5 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 9ff58b94980f..5158fc75d21b 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.83 2012/03/25 17:09:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.84 2012/04/06 08:00:09 tetromino Exp $
+
+ 06 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gtk-vnc-0.5.0.ebuild, +files/gtk-vnc-0.5.0-pulseaudio-automagic.patch:
+ Make pulseaudio optional (bug #399111).
25 Mar 2012; Raúl Porcel <armin76@gentoo.org> gtk-vnc-0.4.4.ebuild:
alpha/ia64/sparc stable wrt #393007
diff --git a/net-libs/gtk-vnc/files/gtk-vnc-0.5.0-pulseaudio-automagic.patch b/net-libs/gtk-vnc/files/gtk-vnc-0.5.0-pulseaudio-automagic.patch
new file mode 100644
index 000000000000..215096ece33a
--- /dev/null
+++ b/net-libs/gtk-vnc/files/gtk-vnc-0.5.0-pulseaudio-automagic.patch
@@ -0,0 +1,55 @@
+From 2262cd59322d8351be5fcb67bf4229cca35c8764 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Fri, 6 Apr 2012 03:33:41 -0400
+Subject: [PATCH] configure: make pulseaudio detection non-automagic
+
+This is to allow building gtk-vnc on a system with pulseaudio and then
+deploying on a system without pulseaudio.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=673570
+---
+ configure.ac | 21 +++++++++++++++++----
+ 1 files changed, 17 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8eebe41..df213d5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -216,11 +216,23 @@ AC_SUBST(VIEW_CFLAGS)
+ AC_SUBST(VIEW_LIBS)
+
+
+-PKG_CHECK_MODULES(PULSEAUDIO, libpulse-simple, WANT_PULSEAUDIO="yes", AC_MSG_NOTICE([Not building against libpulse]))
+-if test "x$WANT_PULSEAUDIO" = xyes; then
+- AC_DEFINE_UNQUOTED([HAVE_PULSEAUDIO], 1,[Define if we have and want pulseaudio.])
++AC_ARG_WITH(pulseaudio,
++ [AS_HELP_STRING([--with-pulseaudio],
++ [use PulseAudio for audio playback @<:@default=check@:>@])],
++ [],
++ [with_pulseaudio=check])
++
++HAVE_PULSEAUDIO=no
++if test "x$with_pulseaudio" != "xno"; then
++ PULSEAUDIO_MODULES=libpulse-simple
++ if test "x$with_pulseaudio" == "xyes"; then
++ PKG_CHECK_MODULES(PULSEAUDIO, $PULSEAUDIO_MODULES, [HAVE_PULSEAUDIO=yes])
++ else
++ PKG_CHECK_MODULES(PULSEAUDIO, $PULSEAUDIO_MODULES, [HAVE_PULSEAUDIO=yes],
++ [AC_MSG_NOTICE([libpulse-simple not found, disabling PulseAudio support])])
++ fi
+ fi
+-AM_CONDITIONAL([HAVE_PULSEAUDIO], [test "x$WANT_PULSEAUDIO" = "xyes"])
++AM_CONDITIONAL([HAVE_PULSEAUDIO], [test "x$HAVE_PULSEAUDIO" = "xyes"])
+ AC_SUBST(PULSEAUDIO_CFLAGS)
+ AC_SUBST(PULSEAUDIO_LIBS)
+
+@@ -477,5 +489,6 @@ Configure summary:
+ Install example programs ...: ${WITH_EXAMPLES}
+ Browser plugin .............: ${enable_plugin}
+ SASL support................: ${enable_sasl}
++ PulseAudio support..........: ${HAVE_PULSEAUDIO}
+ GTK+ version................: ${GTK_API_VERSION}
+ "
+--
+1.7.8.5
+
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild
index 884439d9d03a..8bdf3dc7410b 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild,v 1.3 2012/02/17 04:50:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.0.ebuild,v 1.4 2012/04/06 08:00:09 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
-inherit base eutils gnome.org python
+inherit autotools base eutils gnome.org python
DESCRIPTION="VNC viewer widget for GTK"
HOMEPAGE="http://live.gnome.org/gtk-vnc"
@@ -14,7 +14,7 @@ HOMEPAGE="http://live.gnome.org/gtk-vnc"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples gtk3 +introspection python sasl vala"
+IUSE="examples gtk3 +introspection pulseaudio python sasl vala"
# libview is used in examples/gvncviewer -- no need
# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
@@ -23,13 +23,13 @@ IUSE="examples gtk3 +introspection python sasl vala"
COMMON_DEPEND=">=dev-libs/glib-2.30.1:2
>=dev-libs/libgcrypt-1.4.2
dev-libs/libgpg-error
- media-sound/pulseaudio
>=net-libs/gnutls-1.4
>=x11-libs/cairo-1.2
>=x11-libs/gtk+-2.18:2
x11-libs/libX11
gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
+ pulseaudio? ( media-sound/pulseaudio )
python? ( >=dev-python/pygtk-2:2 )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${COMMON_DEPEND}"
@@ -38,10 +38,14 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
sys-devel/gettext
>=dev-util/intltool-0.40
+
+ gnome-base/gnome-common
+
vala? (
dev-lang/vala:0.14[vapigen]
>=dev-libs/gobject-introspection-0.9.4 )
"
+# eautoreconf requires gnome-common
GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
@@ -59,6 +63,10 @@ src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=667943
epatch "${FILESDIR}/${PN}-0.5.0-pod.patch"
+ # bug #399111, https://bugzilla.gnome.org/show_bug.cgi?id=673570
+ # requires eautoreconf
+ epatch "${FILESDIR}/${PN}-0.5.0-pulseaudio-automagic.patch"
+
python_convert_shebangs -r 2 .
mkdir "${GTK2_BUILDDIR}" || die
mkdir "${GTK3_BUILDDIR}" || die
@@ -73,6 +81,8 @@ src_prepare() {
sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
-i src/Makefile.* || die
+ eautoreconf
+
# Work around https://bugzilla.gnome.org/show_bug.cgi?id=667941
[[ -e GNUmakefile ]] || touch GNUmakefile
}
@@ -82,6 +92,7 @@ src_configure() {
myconf="
$(use_with examples) \
$(use_enable introspection) \
+ $(use_with pulseaudio) \
$(use_with sasl) \
--with-coroutine=gthread \
--without-libview \