summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-07 09:34:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-07 09:34:37 +0000
commita15172c702033b0321a2e7f99b78ce602dc67072 (patch)
tree7f83352ade851341de98959e5d966e3174f63fd2 /net-libs
parentbump (diff)
downloadgentoo-2-a15172c702033b0321a2e7f99b78ce602dc67072.tar.gz
gentoo-2-a15172c702033b0321a2e7f99b78ce602dc67072.tar.bz2
gentoo-2-a15172c702033b0321a2e7f99b78ce602dc67072.zip
Fix USE=dbus (bug #524602).
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog6
-rw-r--r--net-libs/libpcap/files/libpcap-1.6.2-dbus.patch19
-rw-r--r--net-libs/libpcap/libpcap-1.6.2-r1.ebuild3
-rw-r--r--net-libs/libpcap/libpcap-1.6.2.ebuild3
4 files changed, 28 insertions, 3 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index fe571e1312aa..b8c5cd0600c8 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.210 2014/10/07 09:18:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.211 2014/10/07 09:34:37 jer Exp $
+
+ 07 Oct 2014; Jeroen Roovers <jer@gentoo.org> libpcap-1.6.2.ebuild,
+ libpcap-1.6.2-r1.ebuild, +files/libpcap-1.6.2-dbus.patch:
+ Fix USE=dbus (bug #524602).
*libpcap-1.6.2-r1 (07 Oct 2014)
diff --git a/net-libs/libpcap/files/libpcap-1.6.2-dbus.patch b/net-libs/libpcap/files/libpcap-1.6.2-dbus.patch
new file mode 100644
index 000000000000..4855e6e78ffd
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.6.2-dbus.patch
@@ -0,0 +1,19 @@
+--- a/configure.in
++++ b/configure.in
+@@ -1633,16 +1633,6 @@
+ #
+ AC_MSG_ERROR([Due to freedesktop.org bug 74029, D-Bus capture support is not available on OS X])
+ ;;
+- esac
+- else
+- case "$host_os" in
+-
+- darwin*)
+- #
+- # https://bugs.freedesktop.org/show_bug.cgi?id=74029
+- #
+- ;;
+-
+ *)
+ AC_CHECK_PROG([PKGCONFIG], [pkg-config], [pkg-config], [no])
+ if test "x$PKGCONFIG" != "xno"; then
diff --git a/net-libs/libpcap/libpcap-1.6.2-r1.ebuild b/net-libs/libpcap/libpcap-1.6.2-r1.ebuild
index b46321b68da3..d77bbadd4756 100644
--- a/net-libs/libpcap/libpcap-1.6.2-r1.ebuild
+++ b/net-libs/libpcap/libpcap-1.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.6.2-r1.ebuild,v 1.1 2014/10/07 09:18:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.6.2-r1.ebuild,v 1.2 2014/10/07 09:34:37 jer Exp $
EAPI=5
inherit autotools eutils multilib-minimal
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
epatch "${FILESDIR}"/${PN}-1.6.1-configure.patch
epatch "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ epatch "${FILESDIR}"/${PN}-1.6.2-dbus.patch
mkdir bluetooth || die
cp "${FILESDIR}"/mgmt.h bluetooth/ || die
diff --git a/net-libs/libpcap/libpcap-1.6.2.ebuild b/net-libs/libpcap/libpcap-1.6.2.ebuild
index b4cb7118d9f3..e9f4e60085ab 100644
--- a/net-libs/libpcap/libpcap-1.6.2.ebuild
+++ b/net-libs/libpcap/libpcap-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.6.2.ebuild,v 1.2 2014/09/16 21:58:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.6.2.ebuild,v 1.3 2014/10/07 09:34:37 jer Exp $
EAPI=5
inherit autotools eutils
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
epatch "${FILESDIR}"/${PN}-1.6.1-configure.patch
epatch "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ epatch "${FILESDIR}"/${PN}-1.6.2-dbus.patch
mkdir bluetooth || die
cp "${FILESDIR}"/mgmt.h bluetooth/ || die