summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-05 19:14:17 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-05 19:14:17 +0000
commita1d065d32cad0fd7ca3c2afe1f23c85d3b790cf8 (patch)
treeff1b6f3ae0457927bac7c17cdd1044a9a3e06f30 /net-libs
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-a1d065d32cad0fd7ca3c2afe1f23c85d3b790cf8.tar.gz
gentoo-2-a1d065d32cad0fd7ca3c2afe1f23c85d3b790cf8.tar.bz2
gentoo-2-a1d065d32cad0fd7ca3c2afe1f23c85d3b790cf8.zip
Version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.13.1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 6ea198d2323f..9ae44b938f55 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.49 2008/06/03 10:40:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.50 2008/07/05 19:14:17 armin76 Exp $
+
+*rb_libtorrent-0.13.1 (05 Jul 2008)
+
+ 05 Jul 2008; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.13.1.ebuild:
+ Version bump
*rb_libtorrent-0.13_p2335 (03 Jun 2008)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.13.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.13.1.ebuild
new file mode 100644
index 000000000000..37d4d510b33d
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.13.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13.1.ebuild,v 1.1 2008/07/05 19:14:17 armin76 Exp $
+
+inherit eutils autotools
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+DEPEND="dev-libs/boost
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ econf $(use_enable debug) \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}