summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-09 09:12:23 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-09 09:12:23 +0000
commita50950626a3dc3c69361724f590065c362b1d58d (patch)
tree11a08432dd473136ec0b6a17f0ed608b992a6ffe /net-libs
parentMove perl modules from site to vendor. Use more perl-module.eclass (diff)
downloadgentoo-2-a50950626a3dc3c69361724f590065c362b1d58d.tar.gz
gentoo-2-a50950626a3dc3c69361724f590065c362b1d58d.tar.bz2
gentoo-2-a50950626a3dc3c69361724f590065c362b1d58d.zip
fix compilation with gcc-4.4, bug 269328
(Portage version: 13799-svn/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/opal/ChangeLog6
-rw-r--r--net-libs/opal/files/opal-3.6.2-gcc-4.4.patch13
-rw-r--r--net-libs/opal/opal-3.6.2.ebuild4
3 files changed, 21 insertions, 2 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index 79624214c536..1d1dadae813d 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.44 2009/07/03 10:09:58 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.45 2009/07/09 09:12:22 volkmar Exp $
+
+ 09 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/opal-3.6.2-gcc-4.4.patch, opal-3.6.2.ebuild:
+ Fix compilation with gcc-4.4. Fix bug 269328. Thanks to Michal Górny.
*opal-3.6.2 (03 Jul 2009)
diff --git a/net-libs/opal/files/opal-3.6.2-gcc-4.4.patch b/net-libs/opal/files/opal-3.6.2-gcc-4.4.patch
new file mode 100644
index 000000000000..df23e1c6ab22
--- /dev/null
+++ b/net-libs/opal/files/opal-3.6.2-gcc-4.4.patch
@@ -0,0 +1,13 @@
+upstream gcc-4.4 fix (r22667)
+
+diff -dupr opal-3.6.2.orig/plugins/video/H.264/gpl/enc-ctx.cxx opal-3.6.2/plugins/video/H.264/gpl/enc-ctx.cxx
+--- opal-3.6.2.orig/plugins/video/H.264/gpl/enc-ctx.cxx 2009-07-07 21:52:48.237840250 +0200
++++ opal-3.6.2/plugins/video/H.264/gpl/enc-ctx.cxx 2009-07-07 21:53:26.042351938 +0200
+@@ -25,6 +25,7 @@
+ #include "trace.h"
+ #include "rtpframe.h"
+
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <math.h>
+ #if defined(_WIN32) || defined(_WIN32_WCE)
diff --git a/net-libs/opal/opal-3.6.2.ebuild b/net-libs/opal/opal-3.6.2.ebuild
index 71534cc29ba6..46d09ca30547 100644
--- a/net-libs/opal/opal-3.6.2.ebuild
+++ b/net-libs/opal/opal-3.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.2.ebuild,v 1.1 2009/07/03 10:09:58 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.2.ebuild,v 1.2 2009/07/09 09:12:22 volkmar Exp $
EAPI="2"
@@ -119,6 +119,8 @@ src_prepare() {
# upstream patch 2808915
epatch "${FILESDIR}"/${P}-jdkroot.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.4.patch
+
# h224 really needs h323 ?
# TODO: get a confirmation in ml
sed -i -e "s:\(.*HAS_H224.*\), \[OPAL_H323\]:\1:" configure.ac \