summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-16 07:56:57 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-16 07:56:57 +0000
commitbcfa6ba262246286854272c71797ded3d3c2bc1b (patch)
tree1b0a15faebe9123a56d866ba7fb2808771705ef5 /net-libs
parentFix from Chromium OS for cross-compiling. (diff)
downloadgentoo-2-bcfa6ba262246286854272c71797ded3d3c2bc1b.tar.gz
gentoo-2-bcfa6ba262246286854272c71797ded3d3c2bc1b.tar.bz2
gentoo-2-bcfa6ba262246286854272c71797ded3d3c2bc1b.zip
Fix from Chromium OS for cross-compiling.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/neon/ChangeLog8
-rw-r--r--net-libs/neon/files/neon-0.30.1-xml2-config.patch15
-rw-r--r--net-libs/neon/neon-0.30.1.ebuild7
3 files changed, 25 insertions, 5 deletions
diff --git a/net-libs/neon/ChangeLog b/net-libs/neon/ChangeLog
index b8d6854a014d..c259a936022d 100644
--- a/net-libs/neon/ChangeLog
+++ b/net-libs/neon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/neon
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.93 2014/12/06 16:41:07 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.94 2015/05/16 07:56:57 vapier Exp $
+
+ 16 May 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/neon-0.30.1-xml2-config.patch, neon-0.30.1.ebuild:
+ Fix from Chromium OS for cross-compiling.
06 Dec 2014; Agostino Sarubbo <ago@gentoo.org> neon-0.30.1.ebuild:
Stable for ia64, wrt bug #529718
diff --git a/net-libs/neon/files/neon-0.30.1-xml2-config.patch b/net-libs/neon/files/neon-0.30.1-xml2-config.patch
new file mode 100644
index 000000000000..1290101844ca
--- /dev/null
+++ b/net-libs/neon/files/neon-0.30.1-xml2-config.patch
@@ -0,0 +1,15 @@
+locate the $CHOST prefixed version of xml2-config by default
+
+would be better to use pkg-config here, but this patch is minimally invasive
+
+--- a/macros/neon-xml-parser.m4
++++ b/macros/neon-xml-parser.m4
+@@ -44,7 +44,7 @@ AC_CHECK_HEADER(expat.h,
+
+ dnl Find libxml2: run $1 if found, else $2
+ AC_DEFUN([NE_XML_LIBXML2], [
+-AC_CHECK_PROG(XML2_CONFIG, xml2-config, xml2-config)
++AC_CHECK_TOOL(XML2_CONFIG, xml2-config, xml2-config)
+ if test -n "$XML2_CONFIG"; then
+ neon_xml_parser_message="libxml `$XML2_CONFIG --version`"
+ AC_DEFINE(HAVE_LIBXML, 1, [Define if you have libxml])
diff --git a/net-libs/neon/neon-0.30.1.ebuild b/net-libs/neon/neon-0.30.1.ebuild
index 51e43dd06699..7d255cb055fc 100644
--- a/net-libs/neon/neon-0.30.1.ebuild
+++ b/net-libs/neon/neon-0.30.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/neon-0.30.1.ebuild,v 1.10 2014/12/06 16:41:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/neon-0.30.1.ebuild,v 1.11 2015/05/16 07:56:57 vapier Exp $
EAPI="5"
@@ -53,8 +53,9 @@ src_prepare() {
for lingua in ${IUSE_LINGUAS}; do
use linguas_${lingua} && linguas+=" ${lingua}"
done
- sed -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/" -i configure.ac
+ sed -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/" -i configure.ac || die
+ epatch "${FILESDIR}"/${P}-xml2-config.patch
AT_M4DIR="macros" eautoreconf
elibtoolize