summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-14 13:41:24 +0000
committerEray Aslan <eras@gentoo.org>2011-06-14 13:41:24 +0000
commitc68d6f8c00d7ad3a849c398aa9c46c2fa8e18e29 (patch)
tree969ab2fdbe5f2eaebd2b243a06e2c27bdcbb47f6 /net-libs
parentVersion bump to 2.0.1. (diff)
downloadgentoo-2-c68d6f8c00d7ad3a849c398aa9c46c2fa8e18e29.tar.gz
gentoo-2-c68d6f8c00d7ad3a849c398aa9c46c2fa8e18e29.tar.bz2
gentoo-2-c68d6f8c00d7ad3a849c398aa9c46c2fa8e18e29.zip
Disable nonnull warning for newsnntp.c. QA
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/ChangeLog8
-rw-r--r--net-libs/libetpan/files/libetpan-1.0-nonnull.patch12
-rw-r--r--net-libs/libetpan/libetpan-1.0.ebuild12
3 files changed, 28 insertions, 4 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 6f84024a85a4..689ef199cab3 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libetpan
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.82 2010/04/20 18:41:57 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.83 2011/06/14 13:41:24 eras Exp $
+
+ 14 Jun 2011; Eray Aslan <eras@gentoo.org> libetpan-1.0.ebuild,
+ +files/libetpan-1.0-nonnull.patch:
+ Disable nonnull warning for newsnntp.c. QA
*libetpan-1.0 (20 Apr 2010)
diff --git a/net-libs/libetpan/files/libetpan-1.0-nonnull.patch b/net-libs/libetpan/files/libetpan-1.0-nonnull.patch
new file mode 100644
index 000000000000..0710cfdad94e
--- /dev/null
+++ b/net-libs/libetpan/files/libetpan-1.0-nonnull.patch
@@ -0,0 +1,12 @@
+http://sourceforge.net/mailarchive/forum.php?thread_name=k2vfc2c80ae1004051048n4a2b5ab0y85ab946c2a556544%40mail.gmail.com&forum_name=libetpan-devel
+--- src/low-level/nntp/Makefile.am 2011-06-14 15:37:14.511603732 +0300
++++ src/low-level/nntp/Makefile.am 2011-06-14 15:38:42.000000000 +0300
+@@ -35,6 +35,8 @@
+ AM_CPPFLAGS = -I$(top_builddir)/include \
+ -I$(top_srcdir)/src/data-types
+
++CFLAGS += -Wno-nonnull
++
+ noinst_LTLIBRARIES = libnntp.la
+
+ libnntp_la_SOURCES = \
diff --git a/net-libs/libetpan/libetpan-1.0.ebuild b/net-libs/libetpan/libetpan-1.0.ebuild
index 401f319435d4..c3114fb003a6 100644
--- a/net-libs/libetpan/libetpan-1.0.ebuild
+++ b/net-libs/libetpan/libetpan-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-1.0.ebuild,v 1.1 2010/04/20 18:41:57 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-1.0.ebuild,v 1.2 2011/06/14 13:41:24 eras Exp $
EAPI="2"
@@ -20,9 +20,11 @@ DEPEND="berkdb? ( sys-libs/db )
!gnutls? ( ssl? ( dev-libs/openssl ) )
sasl? ( dev-libs/cyrus-sasl )
liblockfile? ( net-libs/liblockfile )"
+RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-nonnull.patch
eautoreconf
}
@@ -60,6 +62,12 @@ src_configure() {
|| die
}
+src_compile() {
+ # nonnull already checked for newsnntp.c
+ append-flags -Wno-nonnull
+ emake
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc NEWS ChangeLog || die