summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 18:03:55 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 18:03:55 +0000
commitce7118c07ea4f108cdd9301c9bd495fcde2b8106 (patch)
tree6892449309fc4ee2f23e4c30a8f9a3e210961471 /net-libs
parentEnable multilib support. (diff)
downloadgentoo-2-ce7118c07ea4f108cdd9301c9bd495fcde2b8106.tar.gz
gentoo-2-ce7118c07ea4f108cdd9301c9bd495fcde2b8106.tar.bz2
gentoo-2-ce7118c07ea4f108cdd9301c9bd495fcde2b8106.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnice/ChangeLog9
-rw-r--r--net-libs/libnice/libnice-0.1.4-r1.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/net-libs/libnice/ChangeLog b/net-libs/libnice/ChangeLog
index e9adeb4f1080..ddcd5aee6672 100644
--- a/net-libs/libnice/ChangeLog
+++ b/net-libs/libnice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnice
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.64 2013/10/27 09:40:58 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.65 2014/06/10 18:03:55 mgorny Exp $
+
+*libnice-0.1.4-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org> +libnice-0.1.4-r1.ebuild:
+ Enable multilib support.
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> -libnice-0.1.3-r1.ebuild,
metadata.xml:
diff --git a/net-libs/libnice/libnice-0.1.4-r1.ebuild b/net-libs/libnice/libnice-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..12554bd60cbe
--- /dev/null
+++ b/net-libs/libnice/libnice-0.1.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.4-r1.ebuild,v 1.1 2014/06/10 18:03:55 mgorny Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+upnp"
+
+RDEPEND=">=dev-libs/glib-2.13:2[${MULTILIB_USEDEP}]
+ upnp? ( >=net-libs/gupnp-igd-0.1.3:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+multilib_src_configure() {
+ # gstreamer plugin split off into media-plugins/gst-plugins-libnice
+ ECONF_SOURCE=${S} \
+ econf --disable-static \
+ --without-gstreamer \
+ --without-gstreamer-0.10 \
+ $(use_enable upnp gupnp)
+
+ if multilib_is_native_abi; then
+ ln -s {"${S}"/,}docs/reference/libnice/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}