summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-26 23:17:40 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-26 23:17:40 +0000
commitebc09b037483ae0f274fe1e5b5f2b60fe40c3898 (patch)
treecb6925dc3d30c744cc7058c9a5e6179391f19bdf /net-libs
parentAdd ~x86-fbsd. #408687 (diff)
downloadgentoo-2-ebc09b037483ae0f274fe1e5b5f2b60fe40c3898.tar.gz
gentoo-2-ebc09b037483ae0f274fe1e5b5f2b60fe40c3898.tar.bz2
gentoo-2-ebc09b037483ae0f274fe1e5b5f2b60fe40c3898.zip
Remove LDFLAGS from pkg-config Libs (bug #409661).
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog6
-rw-r--r--net-libs/libssh2/files/libssh2-1.4.0-pkgconfig.patch10
-rw-r--r--net-libs/libssh2/libssh2-1.4.0.ebuild4
3 files changed, 18 insertions, 2 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 70f86f2684dc..71d7843153eb 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.55 2012/03/25 18:37:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.56 2012/03/26 23:17:40 radhermit Exp $
+
+ 26 Mar 2012; Tim Harder <radhermit@gentoo.org> libssh2-1.4.0.ebuild,
+ +files/libssh2-1.4.0-pkgconfig.patch:
+ Remove LDFLAGS from pkg-config Libs (bug #409661).
25 Mar 2012; Brent Baude <ranger@gentoo.org> libssh2-1.4.0.ebuild:
Marking libssh2-1.4.0 ppc64 for bug 409601
diff --git a/net-libs/libssh2/files/libssh2-1.4.0-pkgconfig.patch b/net-libs/libssh2/files/libssh2-1.4.0-pkgconfig.patch
new file mode 100644
index 000000000000..46bb27db4277
--- /dev/null
+++ b/net-libs/libssh2/files/libssh2-1.4.0-pkgconfig.patch
@@ -0,0 +1,10 @@
+--- libssh2-1.4.0/libssh2.pc.in
++++ libssh2-1.4.0/libssh2.pc.in
+@@ -11,6 +11,6 @@
+ URL: http://www.libssh2.org/
+ Description: Library for SSH-based communication
+ Version: @LIBSSH2VER@
+-Libs: -L${libdir} -lssh2 @LDFLAGS@ @LIBS@
++Libs: -L${libdir} -lssh2 @LIBS@
+ Libs.private: @LIBS@
+ Cflags: -I${includedir}
diff --git a/net-libs/libssh2/libssh2-1.4.0.ebuild b/net-libs/libssh2/libssh2-1.4.0.ebuild
index 638f1157cf94..36ed4cf97cba 100644
--- a/net-libs/libssh2/libssh2-1.4.0.ebuild
+++ b/net-libs/libssh2/libssh2-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.4.0.ebuild,v 1.5 2012/03/25 18:37:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.4.0.ebuild,v 1.6 2012/03/26 23:17:40 radhermit Exp $
EAPI="4"
@@ -22,6 +22,8 @@ RDEPEND="${DEPEND}"
DOCS=( README )
+PATCHES=( "${FILESDIR}"/${P}-pkgconfig.patch )
+
src_configure() {
local myeconfargs